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Provider Management 
The Providers chapter stores information about every individual or agency that provides a service to a client. Providers 
include the programs affiliated with the agency, private providers, and public agencies. The Provider data will be populated 
into eCIRTS via data conversion.  
 
The Providers chapter also contains information about the workers associated with a provider, the specific services offered 
by a provider, rates, and other contract-related details. 
 
When you open the Provider’s chapter, a search page opens. You can locate a provider’s record using information about 
the provider.  
 

Searching for a provider record 
1. Select your assigned role that has access to the Provider Chapter and click Go. 
2. Click on the Providers Chapter. 
3. Select Advanced Search, enter the Provider Name and any other criteria in the search.  Click Search. 
4. Select the Providers name from the List View grid. 
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Demographics 
The Provider’s page is the landing page when opening a Providers record. The Provider’s tab contains the basic 
demographic information on service providers and programs. The Provider’s tab will display basic information about 
that provider.   

 

Adding a provider  
You will create new Provider records in eCIRTS within the Provider Chapter.  

1. Open the Providers Chapter 
2. Select File > Add New Provider Search. The Provider Search Page will open. You must search for any existing 

Providers first before you can add any new records. This helps to prevent duplicates in the application. 

 

3. Search for an existing Provider record first. If the provider already exists, click on the target record from the list 
view to open the record and make any necessary modifications. If zero records are returned, select Add New. 

http://wellsky.com/
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4. At a minimum, complete the following fields on the Provider details page: Required fields are marked with a red 
asterisk (*) 
a. Initial Division = defaults to AG and is read only 
b. Provider Name = Will populate with what you entered in the Provider Search. Update as needed 
c. Active = Yes (checked) 
d. External  = Yes (checked) 
e. Additional Attributes = Multi select (select as needed) 

 

4. From the File menu, select Save and Close Provider.  An eCIRTS generated Provider ID will have been 
created for this provider. The Provider ID is required in the Provider Activity Import file and is part of the 
<SubmitterID> 

5. The Division details page automatically displays. Update the following fields: 
a. Division = defaults to AG and is read only 
b. Status = Open 
c. Status Date = the date you are opening the record. Make this date earlier than any activity record 

you plan to import. We've been using 1/1/2020 or 1/1/21.   
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5. From the File menu, select Save and Close Division. 
 

Edit a provider  
You will be able to edit the basic Provider information which includes the provider’s name, number, contact information 
and address.  

1. Open the provider record in the Providers Chapter. Select the Providers tab if necessary. 
2. Select File >  Edit Provider from the file menu and the details page opens. 
3. Update any fields as needed.  
4. From the File menu, select Save and Close Provider when complete. 

 

Provider Addresses 
Provider addresses will appear on the Addresses subpage along with other addresses of the same type. There can be 
several addresses for each of the Contact, Mailing and Correspondence types. There can be one address type selected as 
primary which will then display on the main provider page under the specific section for that address type.  
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Add Provider addresses 
1. Open the provider record. Select the Providers tab. 
2. Select File > Edit Provider. The Provider detail page opens. 
3. Add the Provider address information in the following two sections: 

Contact Address (Physical Location) 

This section contains the address for the provider’s physical location.

 

Mailing Address 

This section contains the address for mailing purposes. 

 

 

4. To save additional provider addresses, select Addresses from the left-hand navigation menu.  

 

5. The Addresses list view page opens. Existing addresses are shown in the list view grid. To edit an existing 
address, select it from the list view grid. 

6. Select File > Add Address to add a new address. 

http://wellsky.com/
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7. Complete the address information. Select File > Save and Close Address when complete.  

 
 
 

Note: In order for the address to appear on the Provider detail page the Address Type 
must be Contact or Mailing and the record must be marked as the primary address and 
active.  
If the address type dropdown includes additional address types such as billing and the 
address is associated to that type, it will not display on the Provider detail page. The 
address will only appear on the Address subpage.  
 

 

Provider Telephone Numbers 
Provider records can include many different telephone numbers. The phone numbers are saved in the Telephone 
number subpage in the Provider record.  

Add Provider telephone numbers 
1. Open the provider record. Select the Providers tab. 
2. Select File > Edit Provider. The Provider details page open. 
3. To add a phone number via the detail page, locate the phone number field and enter the number.  
4. Select File > Save Provider when done. When you save the provider record, the phone numbers will be listed on 

the Telephone Number(s) subpage. 
5. To add a phone number via the Telephone Number(s) subpage, select Telephone Number(s) from the left hand 

navigation. The Telephone Numbers list view page opens. Phone numbers added via the detail page will be 
displayed in the list view. To edit a phone number, select it from the list view.  
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6. To add a phone number, select File > Add Telephone Number. The Telephone Number page opens.  

 

7. Complete the telephone number information. Required fields are marked with a red asterisk (*) 
8. Select File > Save and Close Telephone Number when finished.  

Division 
The Division tab lists all Divisions to which the provider is open.  A provider or program has to be opened to a division in 
order for clients to be enrolled or for services to be delivered. If you need to view the existing Division record then 
complete the following steps.  

1. Open the Provider record and select the Division tab. 
2. Select the  Division record that you want to view from the list view grid. 

 

3. The Division Details page opens.   

http://wellsky.com/
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4. The Division page elements include: 
a. Division*: All Providers will be associated with AG. 
b. Status*: This field is used to track the status of the Provider within the Division. The Provider will need to 

be in an Open status in order to deliver services.  
c. Status Date: This field is used to record the date for the status. 
d. Open Date: The date the Division is open to the Provider. 

Workers 
The Workers tab contains information about employees of the provider.  Each employee is entered into the system 
individually. Workers must have a worker record associated to a provider to have access to records in eCIRTS. Other worker 
information you can capture in this tab include the worker’s supervisor name, worker credentials, experience, and basic 
demographic data. These are the people that will be delivering the services on behalf of the Provider. The eCIRTS 
generated  <Member ID> for each of these workers is required in the Provider Activity Import file and are the people that 
delivered the services to the client. 

1. To view the Workers tab, open the Provider record and select the Workers tab. Existing worker records, if any, 
are shown in the list view grid 

http://wellsky.com/
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Adding a worker  
Before you can add a new worker record, you must conduct a search to make sure that the worker doesn’t already exist. 
This helps to prevent duplicate records. Provider workers will be added into eCIRTS via the initial data conversion.  If the 
Provider needs a new worker added, the user will follow the steps outlined below.  

To add a worker to the Provider record. 
1. Open the Provider record and select the Workers tab. 
2. Select File > Add New Worker Search. The Worker Search page opens. 

 

3. Enter in the Search criteria and click Search. 
4. To add a worker who already exists, select the checkbox at the end of the record row.  Select Add 

Worker to Provider under the Tools Menu. Don’t click on the Worker's name. That will take you to the 
worker details page which is not where you add the Worker to the Provider. 

http://wellsky.com/
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5. To edit the existing worker record, select it from the list view grid.  The Worker record opens. 
6. To add a new record, select Add New. The Worker page opens. 

 

7. Complete the worker information.  Any information you entered in the worker search filter will pre-
populate in the worker detail screen.   

8. Select File > Save and Close Worker when done. An eCIRTS generated Member ID has been assigned to 
this worker. The worker has been added to the Provider's record. 

Editing a worker  
1. Open the Provider record and select the Workers tab. 
2. Select the worker’s record from the list view grid. If necessary, use the filters to locate the worker record.  

The Worker page opens.  
3. Edit the worker information as needed.  Select File > Save and Close Worker when done. 

http://wellsky.com/
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Deactivating or excluding a worker  
When a worker leaves your organization, you will want to make that worker inactive to prevent the worker from accessing 
the application and to remove that worker’s name from the worker search popup or worker dropdown lists throughout 
the application.  

Current records with the worker’s name will remain in place.  If the worker is associated with multiple providers,  you will 
make that worker inactive for all providers when you make the current worker record inactive.  

To exclude an active worker from displaying in the various Worker dropdown lists, select the “Exclude from List” option 
in the worker record. The exclude option will allow the worker record to still be active so the user can still access the 
application, but the worker’s name will not display in the worker search or dropdown lists. When a worker who has been 
excluded from the worker dropdown list adds a record to the application and that field is set to default to the current 
worker, their name will still display in the field. 

To mark a worker as inactive or excluded 

1. Open the Provider record and select the Workers tab. 
2. Select the worker’s record from the list view grid.  The Worker page opens.  
3. To deactivate a worker, clear the “Active” option.  Inactive workers are automatically not included in the worker 

dropdown lists throughout eCIRTS.  If the worker is associated with multiple providers when the record is 
deactivated the worker will be inactive for all providers.  

http://wellsky.com/
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4. To exclude an active worker from displaying in the various Worker dropdown lists in eCIRTS, select the “Exclude” 
option.  This action will allow the worker record to still be active so the user can still access the application but 
will not display in the worker search or dropdown lists.  

5. Select File > Save and Close Worker when done.  
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Adding and editing a supervisor 
The worker’s supervisor is a significant piece of information in eCIRTS. Many options, like notes are editable by both a 
worker and the worker’s supervisor.  Outstanding ticklers are visible to a worker’s supervisor.  

A worker can have one or more supervisors but only one supervisor can be flagged as the primary supervisor. The primary 
supervisor is the worker who will see the worker’s ticklers in the My Work chapter.   

To add or edit a worker supervisor 

1. Open the Provider record and select the Workers tab. 
2. Select the worker’s record from the list view grid.  The Worker page opens.  
3. Select the name of the worker’s supervisor from the dropdown list. The Supervisor field is not a required field.  
4. When you add the supervisor and save the record, the supervisor field will become read-only. Use the 

Supervisors subpage to change or edit the supervisor.  
5. You can add additional supervisors on the Supervisor subpage. The Supervisor subpage is available after you 

save the Worker record.  Select Supervisors from the left-hand navigation.  

http://wellsky.com/
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6. Select File > Add Supervisor. The Supervisor Details page opens.  
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7. Select the Supervisor name from the dropdown. Complete the Supervisor information as needed.  Required 
fields are marked with a red asterisk.  

8. Select File > Save and Close Supervisor when done.  

 
 
 

Note: If you need to change the primary supervisor, add the new supervisor, and select 
the primary field for that supervisor. When you save the worker record, the former 
primary supervisor is still show as a supervisor, but the primary option is clear.  
 

Adding a provider to the worker record 
The Providers list view page shows the providers with whom the worker has been associated. When you add a worker to 
a provider record, that provider name is automatically captured on this page.  Add more provider records to capture 
additional worker experience and associations.  

When you add a provider to the worker record using the Worker Provider page, the worker will also appear on the new 
Provider’s Worker page. You must give workers access to import the provider activity file for this provider and access to 
view the import error logs. 

To add a provider to the worker record 

1. Open the Provider record and select the Workers tab. 
2. Select the worker’s record from the list view grid.  The Worker page opens.  
3. Select Providers from the left-hand navigation. The Providers list view page opens.  Existing provider records, if 

any, are show in the list view. Select the name of the Provider for which this Worker should have access to 
import files if applicable. 
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4. Select File > Add Worker Provider from the menu. The Worker Provider Details page opens.  

 

5. Use the Provider name search ellipsis ( ) to search for the provider’s name.  The Provider search popup 
opens.  

a. Select the search criteria from the Search By dropdown. 
b. Type the search criteria in the Search text bar. 
c. Click Search 
d. Select the provider’s name from the search results.  

 

 

6. Select Upload HIPAA Files if this worker should be able to upload Provider Activity Import files for this provider.  
7. Select Download HIPAA Files if this worker should be able to download and view the import error logs.  
8. Complete the worker provider information.  Required fields are marked with a red asterisk. 
9. Select File > Save and Close Worker Provider when done.  

Deactivating a worker from a provider 
If you want to mark a worker as inactive for a specific provider, you will need to edit the Provider subpage information in 
the Worker record. 

 
 
 

Note: You cannot make the primary provider inactive. To mark this provider as inactive, 
you must first mark another provider as the primary provider.  
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To mark a worker as inactive for a specific provider 

1. Open the Provider record and select the Workers tab. 
2. Select the worker’s record from the list view grid.  The Worker page opens. 
3. Select Providers from the left-hand navigation. The Providers list view page opens.   

 

4. Select the provider from the list view grid. The Worker Provider page opens.  
5. Clear the Active option checkbox. 
6. Select File > Save and Close Worker Provider when done.  
7. The worker will no longer see any members that are associated to the provider when the Active field is cleared if 

the worker’s role permissions are set, and the Show Discharged Clients Field is cleared.  
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Services 
The Services tab is where you can record the services that a provider would offer to the community  To establish provider 
services in eCIRTS use the Service Code utility to create services and then link each service to the program or provider. A 
client must be enrolled with a program or provider before services can be recorded in authorizations or activities for a 
client.  

To view the Services tab 

1. Open the Provider record and select the Services tab. 
2. Existing services, if any, are shown in the list view grid 

  

To add Services to the provider record 

1. Open the Provider record and select the Services tab. 
2. Select File > Add Services  
3. The Add Services page will open in a new window.  Enter the necessary information in the appropriate fields. 
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4. To select a service, click on the ellipsis search button     next to the Service ID field. Another window will open 
up presenting a list of services to select for that provider.  Scroll through the list view or use the Search By and 
Search Text fields to locate a service code.  

 

 

 
 
 

Note: The list of services is populated through the Service Code Utility. The services 
available for each provider are listed in the Service Code Search popup window. 
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5. Select the service code from the list view. The service code details will populate the Add Services page with data 
recorded in the Service Code Utility. Complete the service code information.  

6. From the File menu, select Save and Close Services or Save and Add Another if you have more to add. 

 
 
 

Note: The Service codes must be set up in the Service Code Setup Utility before you can 
add a service to a program or provider. For assistance, please contact your System 
Administrator.  
 

 

Provider Services Page Elements 

The Services page contains the main Service section and access to the Conditions and Service Area subpage (in the left-
hand navigation). Below is a list of the standard field descriptions that could appear on these pages.  Based on your 
agency’s configuration of the application some of these fields may be hidden and not visible on the page.  

a. Division – This non-editable field defaults to “AG” 
b. Service ID – This non-editable field displays the service ID, which is defined in the service code record created in 

the Service Code Utility.  This is a system-required field. 
c. Service Code – This non-editable field is auto-populated from the service code record created in the Service Code 

Utility. 
d. Unit Type – The non-editable field displays the segment of time allocated to each service session.  This field is 

defined in the service code record created in the Service Code Utility. 
e. Service Description – The non-editable field displays the name of the service, which is defined in the service code 

record created in the Service Code Utility. 
f. Program  - These are the programs under which the provider will be delivering services. 
g. Secondary Code – The field provides an additional code. The data is defined in the service code record created in 

the Service Code Utility, but the user can modify the secondary code that would be specific for that agency. This 
is a system-required field.  

h. Active Date – The date the service can start to be dispensed. This date is auto-populated from the service code 
record created in the Service Code Utility but can be edited.  This is a system-required field.  

i. Service End Date – This date field records the date the service has ended and no longer should be used 
j. Reimbursement Unit Rate  – The price charged for each service session. This is a system-required field 
k. Provider Cost per Unit – This field will populate with the unit cost for this service that was uploaded from CIRTS 

in the Utilities chapter. If this  vendor's unit cost for this service is different than it should be updated in the Unit 
Cost field.  

l. Billable – If checked, this service is billable. 
m. Require Authorization – An authorization is required before a member can receive the service. 
n. Allow Overlap – When selected, a member receiving the service can have overlapping start and end dates. 
o. Authorization Allowed – When selected, the service code is included in the list of provider services available to 

include in an authorization in both add and edit modes. 
p. Provider Conditions Apply – Indicates that the service is using the conditions recorded under the Provider 

Conditions tab. Selected by default. 
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q. Provider Service Areas Allow – Indicates that the service is using the service areas recorded under the Service 
Areas tab. Selected by default. Clear this option to record service areas specific to this service. 

r. Active – Indicates that this service is active in the system. The service will display when a referral search is 
conducted in the Referrals tab or when adding a service to the members record for the specific provider/agency.  
Selected by default. 

 
 
 

The eCIRTS generated <VendorServiceID> is created when the provider service is added. 
This number is unique to the service and the vendor and is required in the Provider 
Activity Import file. This value is not visible in the application but is included in the 
Provider Activity Import Data Report.  
 

 

Updating services 
 
To update services records in the provider record 

1. Open the Provider record and select the Services tab. 
2. Select the record you want to edit from the list view grid. The Services page opens.    

 

3. Edit the service information as needed.  
4. To remove the service, select File > Delete Services. 
5. Select File > Save and Close Services when done.  

Service Area 
Service areas are the locations in which service can be delivered. Most services use the provider’s service area location, 
which is recorded in the provider Service Areas tab. This default setting is in place when the “Provider Service Areas Allow” 
field is selected on the Services page. some PSAs assign by County, some by City. So, when you're adding service areas, don't 
necessarily start at the top of the page and go down. Start at the level you define service areas, and the rest will auto populate 
accordingly. 
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If you are setting up a service that will be offered in a different, or more limited service area, clear this setting and then 
save the more specific service area. 

 
 
 

Note: Adding the service area record under the Services page creates an additional 
record that is associated with the specific service and does not affect the Service Areas 
record under the Service Areas tab in the main provider record.   
 

 

Referrals/Notifications 
The Referral/Notifications tab shows the client referrals/notifications with a single provider in a list view grid. Use this 
tab to view the referrals and/or notifications. Client referrals/notifications can only be edited from within the client’s 
record.  

 

To view the Referrals/Notifications 

1. Open the Provider record and select the Referrals/Notifications tab. 
2. Existing Referrals/Notifications are displayed in the list view grid. 
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3. Select the referral/notification record that you want to view from the list view grid. The Referral/Notification 
detail page displays. 

4. Select File > Close Referral Detail to close the page.  
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Authorizations 
The Authorization tab displays the authorizations for the specific Provider.  The authorization information will all be read 
only as it is informational for the Providers.  

1. Open the Provider record and select the Authorizations tab. 
2. Using the Filters Search, enter the filter criteria for the authorization that needs to be viewed.  Click Search. 

 

3. Select the Authorization record that you want to view from the list view grid. 
4. The Authorization details page opens   

 

5. The Authorization page elements include: 
a. Division*: This field will default to AG. 
b. AuthID: This field displays the Auth ID. 
c. Start Date: Start Date of the Authorization.  
d. End Date: End Date of the Authorization. 
e. Provider*: This field will display the Providers name for the authorization. 
f. Date Authorized: This field displays the date the authorization was created. 
g. Requested By: This field displays the name of the person that requested the authorization. 
h. Requested Date: This date reflects when the authorization was requested. 
i. Status: This field reflects the disposition of the authorization. 
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Auth Service 
Authorized Services are the specific services that the provider will deliver to the client. Authorized services can be added 
to existing authorizations from within the client record.  The Auth Service in the Provider Chapter is for information only.  
An authorization may have an unlimited number of authorized services. The same service can be used twice on the same 
authorization with overlapping dates only if the “Allow overlaps” option has been selected during the service code 
setup.  
The same service can be used on two separate authorizations for the same client with no restrictions. The same service 
code may be available with different unit types and/or unit costs for a single provider. These are considered different 
services and they can be used twice on an authorization. 

 

 

Contracts 
Provider contracts allow an agency to set a maximum limit on the amount of funds a provider will receive.  Though they 
can be used in combination with authorizations, the most common use is for services that are delivered without an 
authorization (for example, targeted case management, guest meals and prevention services).  

To view the Contracts tab 

1. Open the Provider record and select the Contracts tab. 
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Adding contracts 
 
To add a contract to a provider record 

1. Open the Provider record and select the Contracts tab. 
2. Select File > Add Contracts. The Contract page opens. 

 

3. Complete the contract information. Required fields are marked with a red asterisk (*).  
4. Select File > Save Contracts when done. When the record is saved the page refreshes and the Contract Services 

subpage becomes available.  

To add contract services 

1. Open the Provider record and select the Contracts tab. Existing contract records are shown in the list view grid. 
2. Select the target record from the list view. The Contract page opens. 
3. Select Contract Services from the left-hand navigation. The Contract Services List view page opens. Existing 

contract services if any are shown in the list view grid. 
4. Select File > Add Contract Services. The Contract Service subpage opens. 
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5. Complete the contract information. Required fields are marked with a red asterisk (*). If needed, use the search 
ellipsis tool to find the service code. 

6. Select File > Save and Close Contract Service when done.  

Contract Services page elements 

a. Service Code – Use this ellipsis search field to select the service associated to a contract. This is a system-
required field. 

b. Effective Date – This read-only field populates with the Service Code effective date. This is a system-required 
field. 

c. End Date – This read-only field populates from the Service Code end date field. 
d. Active – This read-only field checkbox field populates from the Service C ode after it has been selected. This is a 

system-required field. 
e. Max Units Allowed – This numeric field allows the user to record the allowed max units. 
f. Comments – This text field allows the user to record more in-depth descriptions of the contract service. This 

field allows up to 500 characters. 
g. ServiceID – ID for Service 
h. Max Amount Allowed -  This numeric field allows the user to record the Maximum allowed amount  
i. State Federal Share – Amount of State Federal Share 
j. County Served – County where services are provided 

Notes 
The Provider notes tab is the central location to view provider notes created in other areas of the application and also to 
create new notes from this page. You can attach files to provider notes (images in jpeg, gif and tif formats, PDF, 
Microsoft Word® and Microsoft Excel®). You can route notes to another worker, where they will appear in the worker’s 
My Work chapter as well as in the provider notes tab.  

To view a Provider Note 

Open the Provider record and select the Provider Notes tab. Existing Provider notes are shown in the list view grid. 
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Adding a note 
1. Open the Provider record and select the Notes tab. Existing note records are shown in the list view grid. 
2. Select File > Add Notes from the file menu.  
3. The Notes Details page opens 
4. Complete the note information. Required fields are marked with a red asterisk (*) 
5. Select File > Save and Close Notes from the File menu when done.  
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Note: When you save the note record status as draft, the text field will display as a single 
text field and is editable by the author and their supervisor. If another user opens the 
draft note record, the text field will be non-editable.  
When you save the note record status as pending, this field may be configured so that 
any user accessing the note will be able to make edits directly into the note box.    
 

 

Note page elements 

a. Division  – This defaults to AG. This is a required field 
b. Note Date – Record the date the note was added.  This is a required field. 
c. Note By – This worker dropdown records the worker who is adding the note. This is a required field.  
d. Note Type – Select the note type 
e. Note Subtype – Select the note subtype. This dropdown will only show values that apply to the selected note 

type.  
f. Description –  Use this text field to create a subject line for the note. 
g. Note – Use this text box to record the notes contents. The note text box accommodates up to 25,000 characters. 
h. Status – Select the note status.  
i. Date Completed – This date field populates with a date when the status of the note is saved as complete. This 

field is read-only.  

Routing a Provider note to another worker 
1. Locate the Notes Recipients section at the bottom of the Notes page. Use the search ellipsis to search for a 

worker to add as a recipient.  

 

2. The Worker search popup appears. You can search by the worker’s last name or the provider’s name.  
3. Select the search field from the Search by list and type the search criteria in the Search Text entry box.  
4. Click Search. 

 

5. Click to select the worker from the search window. The worker’s name will appear in the Note Recipients list 
view.  

6. Select File > Save and Close Notes from the File menu.  
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Add an attachment to a note 
1. From the open Notes Detail page, click Add Attachment in the Attachments section.  

 

2. The File Upload Form page opens. Click the Browse button to select the file. Navigate to the file location and 
select the appropriate file.  

 

3. Complete the attachment information and click Upload. The attachment information is shown in the Document 
section of the Note page. If the note is in a pending status, you can use the Remove link to remove the 
attachment. When the note is in a complete status, you can no longer remove the attachment.  

 

4. Select File > Save and Close Notes when done. You can see which notes have attachments in the Notes Page list 
view Attachment column.  
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Editing a note 
You can edit a note to add text or an attachment or to route the note to another user. The note status changes the way 
that you can edit a note 

• Draft – The large note text field displays as a single text field and is editable by the author and their supervisor. If 
another user opens the draft note record, the note text field is read-only. 

• Pending – Any user will be able to make edits directly into the note box.  You can remove attachments from a 
note in pending status. 

• Complete – The note record becomes read-only. 

To view and edit the provider note in the provider record 
1. Open the Provider record and select the Notes tab. Existing note records are shown in the list view grid. 
2. Select a note from the list view to open it. The Notes detail page opens. Edit the note information as needed. 
3. Select File > Save and Close Note when finished.  
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Agencies 
The Agency tab records all the agencies that the provider is associated to from within the Provider record. The Agencies 
tab is a read-only list that displays the Agency ID, Agency Name, Start and End Date.  
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Provider ID Numbers 
The Provider ID Numbers tab records the different identification numbers (IDs) an agency may have.  

To view the Provider ID numbers tab 

1. Open the Provider record and select the Provider ID Numbers tab. Existing Provider ID Numbers are shown in 
the list view grid. 

 

Adding Provider ID Numbers 
 
To add Provider ID numbers to the record 

1. Open the Provider record and select the Provider ID Numbers tab.  
2. Select File > Add Provider ID Number. The Provider ID Number page opens. 

 

3. Complete the ID number information. Required fields are marked with a red asterisk (*). 
4. Select File > Save and Close Provider ID Numbers when done.  
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Provider ID Number page elements 
a. Division – This field defaults to “AG” and is a system-required field. 
b. Identifier/Value – the eCIRTS generated Provider ID for the provider, underscore with no spaces, then the first 5 

letters of the Provider name, including spaces would be the “SenderID” as an example  
• i.e. - SUNCOAST PROVIDERS (10211) = 10211_SUNCO 
• i.e. - ALL SERVICES PROVIDER (10357) = 10357_ALL S 

c. Start Date – The earliest date the provider can upload activity files 
d. End Date – Enter the end date for the ID. 
e. Active – This checkbox indicates the status. This field defaults to active when adding a new record. 
f. Type – SenderID   
g. Comment – Add a comment 

Editing Provider ID Numbers 
 
To update the  Provider ID number record 

1. Open the Provider record and select the Provider ID Numbers tab.  
2. Select the record from the list view grid. The Provider ID Number page opens.  

 

3. Change the provider number information as needed.  
4. To delete the provider number, select Delete Provider ID Number from the File menu. A confirmation message 

appears.  Click OK to continue. 
5. Select File > Save and Close Provider ID Number when done. 

Linked Provider 
The Linked Providers tab shows the relationship between a parent agency and subsidiaries. The subsidiaries are known as 
child providers. You can use this page to copy information from the parent provider to the subsidiary, or child provider. 
You can edit the child information without applying those changes to the parent agency.   

Viewing the Linked Providers page 

• Open the Provider record and select the Linked Providers tab. If a linked provider relationship exists, it is shown 
in the list view grid.  
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Adding a linked Provider 
 
To add a provider link relationship to an existing provider record 

1. Open the Provider record and select the Linked Providers tab.  
2. Select File > Link to a Vendor. The Link a Provider page opens 

 

3. Select the Relationship type from the dropdown. 
4. From the Provider field, use the search ellipsis to locate a provider record. The provider search popup appears.  
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5. Select a search field from the Search by dropdown and then type your search criteria in the Search Text entry 
bar.  Click Search. 

6. Click to select the parent provider from the popup window. The search popup closes, and the provider 
information is shown in the Link a Provider page. 

7. Enter a link Start Date and End Date as needed. 
8. Select File > Save and Close when done.  

Unlinking a linked Provider 
 
To remove a linked provider from the provider record 

1. Open the Provider record and select the Linked Providers tab.  
2. Use the checkbox next to the provider’s name in the list view grid to select the linked provider. 
3. A confirmation message appears. Click OK to continue. The record will be unlinked and will be removed from the 

list view grid. A second confirmation message appears. Click OK. 
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Service Area 
The Service Areas tab contains information about what areas the provider serves in the community. Providers can also 
have service-specific service areas. A master Service Area record must exist for the Provider first before service-specific 
service areas can be added. 

1. Open the Provider record and select the Service Areas tab. Each Provider will have a single service area record.  

 

2. Select File > Edit Service Area to edit an existing Service Area.  

 

3. Select File > Add Service Area to add a new Service Area.  
4. The Service Area page displays. Select or update the service area. Select the values in the left-hand box and move 

them to the right-hand box using the arrows. 
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Note:   
Select the most specific level of service area first and the application will populate other 
details. Do not go top down. For example, when you select the zip code, the application 
will populate the appropriate state, region, county, and city fields. 

  

 

 

 

 
 
 
 

Note:   
To select multiple values, press CTRL while you select the values you want to apply. 
Use the arrow button to move the value from the left box to the right box. 
• The double right arrow button will move all value from the left to right 
• The single right arrow button will move selected values from left to right 
• The single left arrow button will move all values from right to left 
• The double left arrow button will move selected values from right to left 

 

5. Select File > Save and Close Service Area when finished.  
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Rate Change Utility 
At the change of fiscal year or occasionally mid—year, the unit cost or rate for a number of services may need to be 
changed. The Rate Change utility allows the unit cost or rate for one or many services to be easily changed in a single 
session, eliminating the need to change rates on a service code by service code basis.  

The utility allows rates to be changed at the system level and at the provider level, permits the service code and/or the 
unit cost to be end dated, and permits deactivation of defunct service codes. Current data is exported to a spreadsheet, 
changes are made, and then the spreadsheet is imported back into eCIRTS. Data validation is performed, and error logs 
are automatically generated if a problem is detected with the import. Reports detailing the history of rate changes at 
both the system and provider levels are available.  

Additional software requirements 
The Rate Change Utility generates exports, and imports Microsoft Excel spreadsheets. Microsoft 2000 or 2003 is 
required at a minimum in order to use the utility.  

Overview of the utility 
The Rate Change utility allows rates to be quickly and easily changed. 

1. Use search filters to isolate the service codes for which you will change the rates. 
2. Export the service codes to a Microsoft excel spreadsheet. 
3. Update the rates. 
4. Import the new rates into eCIRTS. 

Accessing the utility 
The Rate Change utility is available through the Utilities chapter. Once the utility has been opened, there are 3 options 
available: 

• Export System  Level Service Codes 
• Export Provider Level Service Codes 
• Import Service Codes 

 

Identifying and exporting system service codes 
System-level service codes are the templates you can use when adding services to specific providers. 

 
 
 

Note: It is recommended that you generate a new export each time you update rates. 
Data changes you make through the user interface may  cause errors or conflicts on 
import if the export is based on out-of-date data. 
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Search filters 
The first step in changing rates is to identify the affected service codes using a series of filters. When the filters are 
completed and you search for records, the search results will display the first 100 service codes that meet the specified 
criteria. These 100 service codes act as a preview so you can further refine the filter criteria if needed. The exported 
spreadsheet will contain all service codes that meet the criteria, even if there are more than 100.  

• Billable – indicates whether a service code is billable, user-defined, or visible on the Service Codes Detail 
subpage.  

• Effective Date – the earliest date that a service code can be used. The effective date is user-defined and visible 
on the Service Codes Detail subpage.  

• End Date – last date a service code can be used. The end date is user-defined and visible on the Service Codes 
Detail subpage. 

• Fund Code – fund codes (Division record) are associated with individual unit cost/rates, and  a service code can 
have different rates for each fund code. The fund code is user-defined and visible on the Unit Costs subpage.  

• Last Changed Date – the date of the most recent save. The date is system-generated and visible in the history or 
upper right corner of the screen on the Service Codes Detail subpage. 

• Provider Type – types or categories of providers that can render a service. The provider type is user defined and 
visible on the Provider Types subpage. 

• Requires Authorization – when selected, a service code cannot be delivered without an authorization. The 
Requires Authorization field is user defined and visible on the Service Codes Detail subpage. 

• Secondary Code – usually the procedure or unmodified service code. The secondary code is user-defined and 
visible on the Service Codes Detail subpage. 

• Service Code – often a combination of procedure code and modifiers. The service code is user-defined and 
visible on the Services Codes Detail subpage. 

• Service Category – grouping of services by category. The service category is user-defined and visible on the 
Services Codes Detail subpage. 

• Service ID – unique ID assigned to each service code. The service ID is system-generated and visible as a read-
only field on the Service Codes Detail subpage. 

• Service Name – textual description of the service code. The service name is user-defined and visible on the 
Service Codes Detail subpage.  

• Service Type – grouping of services by type. The service type is user defined and visible on the Service Codes 
Detail subpage. 

• Unit Type – how each unit of service is measured ( that is, hour, session). The unit type is user-defined and 
visible on the Service Codes Detail subpage.  

 
 
 

Note: The utility will only return ACTIVE service codes.  
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Effective date of change 

The Effective Date of Change must be indicated prior to exporting services codes. This date indicated indicates the date 
that the new rates will go into effect. The system will use the indicated value (default value is the current date) as a 
default for each exported service code, but the dates can be adjusted on a code-by-code basis prior to import. 

Export to Excel 
This Export to Excel button will not be active until you select one or more service codes. Once the service codes have 
been selected and the effective date of change has been set, click Export to Excel. A dialog box will open, prompting you 
to open, save, or cancel. WellSky recommends selecting Save and saving a copy of the exported file prior to adjusting 
rates. 

 

Indicating new system-level rates 

Spreadsheet format 
The exported spreadsheet includes two major subsections: 

 Informational Data 
 User Input 

 

 Informational data 

Data in the information section is provided for reference and should not be updated or altered by the user. 
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 Report type 

The report type for System Level service codes is always “System.” This is used as a validation point during import. 

Service code data 

The Service Code Data section contains a snapshot of key data visible on the Service Code Detail subpage in the Service 
Codes section of the utilities chapter. 

Unit cost data 
The Unit Cost Data section contains a snapshot of the key data visible on the Unit Cost subpage in the Service Codes 
section of the utilities chapter.  

 User input 

The User Input section is the area of the spreadsheet where you can edit service code information. Do not adjust cell 
formatting. 

 

Excluding service codes 

If a service code is included on the exported spreadsheet that does not need to be updated, delete the row containing 
that service code. 

Effective change date (required) 

This column will be pre-populated with the value specified at the time of export and indicates the start date of the new 
rate. 

Example: Assume service code 123:AA currently has a rate of $5.00. A new unit cost of $6.00 with an effective change 
date of 2/1/19 is imported. The utility will end date the $5.00 rate to 1/31/19 and will create a new unit cost of $6.00 
with a start date of 2/1/19. 

The pre-populated date can be modified for each service code. 
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Deactivate service code (optional) 

If a service code is no longer going to be used, enter a “Y” in the Deactivate Service Code column. The deactivation will 
be effective as soon as the file is imported; there is no mechanism for indicating a specific deactivation date. 

If the service code will remain in use, enter an “N” or leave the column blank. 

Unit cost rate (required unless the service code is being deactivated) 

The new unit cost or rate should be entered in the Unit Cost Rate column. The new rate will have a start date equal to 
the effective change date. 

Unit cost end date (optional) 

If the new unit cost has an end date, enter that in the End Date Service Code column. If the duration the rate will be in 
effect is open-ended, then leave the column blank. 

 Additional optional fields 

End date service code, unit cost rate type, unit cost credential, unit cost max units, unit cost max1, unit cost max2 

Saving the spreadsheet 

Save the spreadsheet when you’ve made the changes you need to make. When you save the file verify the following 
items: 

 The file name ends in .xls 
  All service codes that are not being updated have been deleted from the file 
 All empty rows between the remaining service codes have been deleted 
 The last two lines (export date and export time) are still there 

 
  The effective change date column is populated for all service codes 

Identifying and exporting provider service codes 
Provider level service codes are the service codes assigned to individual providers. Use the Export Provider Level Service 
Codes feature to update these codes. 

Note: WellSky recommends that you generate a new export each time you update rates. Data can be changed through 
the user interface that may cause errors or conflicts on import if the export is based on out-of-date data. 

Search filters 
The first step in changing rates is to identify the affected service codes using a series of filters. When the filters are 
completed and you search for records, the search results will display the first 100 service codes that meet the specified 
criteria. These 100 service codes act as a preview so you can further refine the filter criteria if needed. The exported 
spreadsheet will contain all service codes that meet the criteria, even if there are more than 100. 
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Available search filters: 
 

 Service Category – grouping of services by category. The service category is user-defined and visible on the Service 
Codes Detail subpage. 

 Service Code – often a combination of procedure code and modifiers. The service code is user-defined and visible on 
the Service Codes Detail subpage. 

 Service ID – unique ID assigned to each service code by WellSky Human Services. The service ID is system-generated 
and visible as a read-only field on the Service Codes Detail subpage. 

 Service Name – textual description of the service code. The service name is user-defined and visible on the Service 
Codes Detail subpage. 

 Service Type – grouping of services by type. The service type is user defined and visible on the Service Codes Detail 
subpage. 

 Unit Type – how each unit of service is measured (that is, hour, session). The unit type is user-defined and visible on 
the Service Codes Detail subpage. 

Note: The utility will only return ACTIVE service codes. 

Effective date of change 
The Effective Date of Change must be indicated prior to exporting services codes. This date indicated indicates the date 
that the new rates will go into effect. The system will use the indicated value (default value is the current date) as a 
default for each exported service code, but the dates can be adjusted on a code-by-code basis prior to import. 

Export to Excel 
This Export to Excel button will not be active until you select one or more service codes. Once the service codes have 
been selected and the effective date of change has been set, click Export to Excel. A dialog box will open, prompting you 
to open, save, or cancel. WellSky recommends selecting Save and saving a copy of the exported file prior to adjusting 
rates. 
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Indicating new provider-level rates 

Spreadsheet format 
The exported spreadsheet has two major subsections: 

 Informational Data 
 User Input 

 

Informational data 
Data in the information section is provided for reference and should not be updated or altered by the user. 
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Report type 

The report type for Provider Level service codes is always “Provider.” This is used as a validation point during import. 

Provider ID and provider name 

The Provider ID and Provider Name columns contain the WellSky-assigned vendor number and the name of the provider 
as it appears in WellSky Human Services. 

Service code data 

The Service Code Data section contains a snapshot of key data visible on the Service Code Detail subpage in the Service 
Codes section of the utilities chapter. 

 User input 
The User Input section is the area of the spreadsheet where you can edit service code information. Do not adjust cell 
formatting. 

 

Excluding service codes 

If a service code is included on the exported spreadsheet that does not need to be updated, delete the row containing 
that service code. 

Effective change date (required) 

This column will be pre-populated with the value specified at the time of export and indicates the start date of the new 
rate. 

Example: Assume service code 123:AA currently has a rate of $5.00. A new unit cost of $6.00 with an effective change 
date of 2/1/19 is imported. The utility will end date the $5.00 rate to 1/31/19 and will create a new unit cost of $6.00 
with a start date of 2/1/19. 

The pre-populated date can be modified for each service code. 
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Deactivate service code (optional) 

If a service code is no longer going to be used, enter a “Y” in the Deactivate Service Code column. The deactivation will 
be effective as soon as the file is imported; there is no mechanism for indicating a specific deactivation date. 

If the service code will remain in use, enter an “N” or leave the column blank. 

 End dateservice code  
(REQUIRED unless the service code is being deactivated) 

The new unit cost or rate should be entered in the Unit Cost Rate column. The new rate will have a start date equal to 
the effective change date. 

Note:  The use of End Date Service Code is different at the provider and system levels. At the provider level, each unit 
cost is handled as a unique service code. At the system level, unit costs are child or sub-records of the service code. 

Example: Assume that service code 123:AA is $5.00/unit from 1/1/18 – 12/31/19 and is $6.00/unit starting 1/1/19. At 
the system level, the record for 123:AA would show as a single service code with two rates. At the provider level, 123:AA 
would appear in the provider’s services list twice, once for each rate. 

Saving the spreadsheet 
Save the spreadsheet when you’ve made the changes you need to make. When you save the file verify the following 
items: 

 The file name ends in .xls 
  All service codes that are not being updated have been deleted from the file 
 All empty rows between the remaining service codes have been deleted 
 The last two lines (export date and export time) are still there 

 

  The effective change date column is populated for all service codes 

Importing service codes 
When all rate changes are complete, upload the spreadsheet to the system. When the spreadsheet has been 
successfully imported, the new rates are immediately visible and in effect. 

To import a spreadsheet 

1. Open the Rate Change utility. 
2. Click Import Service Codes. The Import Service Codes page opens. 
3.  Click Browse and select the file to import. 
4. Click Import Data. 
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Validation 
If the file contains errors an error message will appear. If the error(s) are related to file format, the message will simply 
indicate that the file format is invalid. If the error(s) are related to missing or invalid data, the message will allow the 
user to open an Excel spreadsheet that indicates the specific errors by row and column. Only the first 500 errors in a file 
will be reported. In both instances, no data will be updated in the system. 

 

Validation for system-level service code imports 

Informational data 
The application does not update any data contained in the Informational Data section of the spreadsheet, but it does 
check to make sure that key data is intact. 

 Report Type – Must be “System” and must be populated for every service code. 
 Service ID / Service Name – ID must be a number, ID must exist in the system, a combination of ID and name on 

import must match the combination of ID and name in the system, ID must be active. 

 User input 
Prior to updating any records, the system will validate key items in the User Input section of the spreadsheet. 

 Effective Change Date – Must be a valid date and must be later than the current effective date. 
 Deactivate Service Code – Must be “Y”, “N”, or blank. 
 End Date Service Code – Must be a valid date and must be later than the effective change date. 
 Unit Cost Rate – Must be a number with 2 decimal places. 
 Unit Cost Rate Type – Must match a value in the RateType lookup in the system. 
 Unit Cost End Date – Must be a valid date and must be later than the effective change date. 
 Unit Cost Credential – Must match a value in the Credentials lookup. 
 Unit Cost Max Units – Must be a number with 2 decimal places. 
 Unit Cost Max1 – Must be a number with 2 decimal places. 
 Unit Cost Max2 – Must be a number with 2 decimal places. 
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Validation for provider-level service code imports 

Informational data 
Though the system does not update any data contained in the Informational Data section of the spreadsheet, it does 
check to make sure that key data is intact. 

 Report Type – Must be “Provider” and must be populated for every service code. 
 Service ID / Service Name – ID must be a number, ID must exist in the system, a combination of ID and name on 

import must match the combination of ID and name in the system, ID must be active. 
 Secondary Code – Must be present and unchanged. 
 Last Date Changed – Must be present and unchanged. 
 Current Effective Date – Must be present and unchanged. 
 Current End Date – Must be present and unchanged. 
 Current Rate – Must be present and unchanged. 

 User input 
Prior to updating any records, the system will validate key items in the User Input section of the spreadsheet. 

 Effective Change Date – Must be a valid date and must be later than the current effective date. 
 Deactivate Service Code – Must be “Y”, “N”, or blank. 
 End Date Service Code – Must be a valid date and must be later than the effective change date. 
 Unit Cost Rate – Must be a number with 2 decimal places. 

Rate Change utility: reports and related features 

Reports 
Two reports are available to show all service codes and the history of changes for each rate change. These are accessed 
via the reports chapter. 

 System Level Service Codes and Rates 
 Provider Level Service Codes and Rates 

Related features 
The Rate Change utility is often used in conjunction with the Authorization utility. Typically, rate changes would be 
made, and then existing authorizations would be updated to reflect the new rates (mid-year rate changes), or new 
authorizations would be created (new FY).  
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