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Learning Objectives 
1. Search for existing resource records 
2. Add new resource records 
3. Edit existing resource records 
4. Add resource contacts as Worker records 
5. Add Service Areas for the Resource 
6. Add Services for the Resource 
7. Add service specific Service Areas for the Resource 
8. Add additional resource characteristics as Conditions 
9. Link child records to a parent agency (i.e. locations) 
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Resource Management 
eCIRTS offers call tracking and searching of an integrated resource directory that features the AIRS taxonomy to 
efficiently handle increasing Elder Helpline call volume and requests for Information, Referral, and Assistance.  
In Phase 2, the online resource directory will allow clients, caregivers, and loved ones to quickly search for local provider 
organizations and available services within their communities. Using a simple search box or an advanced search feature, 
resources and provider services can be found using a variety of parameters (e.g., service name, service area, provider 
name, etc.) 
Before the resources are available in the resource directory search, they must first be added to eCIRTS in the Resources 
Chapter. The Department will initiate the process of adding a new resource by completing the application process and 
make sure the resource meets required inclusion and exclusion criteria. The Department will add the Resource record to 
eCIRTS, along with applicable taxonomy codes.  
Designated PSA staff, those part of the Referral Workgroup, will finish and maintain the Resource records. The PSAs 
won’t have access to add new Resource records, but they will be able to add additional information to an existing 
record. (i.e. hours, service description, program name, languages spoken, etc.) 

Search for an Existing Resource Record 
The first step for almost every action in eCIRTS is to search for an existing record. If one doesn’t exist, a new record can 
be added.  

1. Select the eCIRTS Admin role which has access to add records to the Resources Chapter and click Go. 
 

2. Click on the Resources Chapter. 
 

3. Select Advanced Search, enter the Resource Name and any other criteria in the search.  Click Search. 

 
 

4. Matches will be displayed in the list view under the search filters.  
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5. Select the Resource name from the List View grid. 

Add a New Resource Record 
You must search for a matching resource record before you can add a new resource record. This practice helps prevent 
duplicate records in the application. The Department will add new resource records. The PSAs can edit them once 
they’ve been added to the system.  
 

1. Use the eCIRTS Admin role and select the Resources Chapter.  
 

2. Select Advanced Search. 
 

3. From the File menu, select Add New Resource Search. 

 
 

4. Enter the Resource name, agency key, street and/or any other search filters. Select Search. 
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 NOTE 
Each search filter contains four parts:  
1. Filter Field: the data point to search on  
2. Operator: the relationship between the filter field and the value described further in the 

table below. 
3. Value: the filter field answer to search on 
4. Connector: the relationship between this filter and other filters in the search. AND tightens 

your search: only returns records that meets ALL filter criteria. OR broadens your search: 
returns records that meet ANY of the filter criteria. 

 

Operator Definition 

Equal To Returns records that match the entered criteria. For example, if <Last Name> is entered 
as “equal to” a specific person’s name, the Member records assigned to that worker will 
be returned. 

Begins With Returns records that begin with the entered criteria. For example, if <Last Name> is 
entered as “begins with” ‘T’ the system will return records assigned to the worker having 
last names that start with ‘T’, such as Tester and Thomas. 

Ends With Returns records that end with the entered criteria. For example, if you search on <Last 
Name> “ends with” ‘r’, you can retrieve records where a Member’s name ends in ‘r’, 
such as Tester. 

Not Equal To Returns records that do not match the entered criteria. For example, if a name is entered 
for <Last Name>, the system will return a list of records except those records for the 
name provided in the search criteria. 

Greater Than Returns records that are dated later than the entered criteria. For example, if <DOB> is 
entered as “greater than” ‘03/01/2015’, the system will return all records whose dates of 
birth are after March 1, 2015.  

Less Than Returns records that are dated earlier than the entered criteria. For example, if <DOB> is 
entered as “less than” ‘03/31/2015’, the system will return data for all records with a 
birth date before March 31, 2015. 

Contains Returns records that contain the entered criteria.  For example, if <Last Name> is entered 
as “contains” specific values in the person’s name, the Member Record(s) assigned to 
that worker with those values would be returned. 

Blank A record is returned where the selected field does not have a value in the field. 

Non-Blank Returns records where the selected field does have a value in the field. 

 
6. If a match is not found, select Add New. Proceed to the Resource Details section.  

 
7. If a match is found, select the Resource name from the List View grid and proceed to Edit a Resource Record. 
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Edit a Resource  
You will be able to edit the basic Resource information which includes the Resource’s name, number, contact 
information and address. The eCIRTS Admin role can edit this information. The ADRC Records Management role can also 
edit it, but cannot add it. 

1. Open the provider record in the Resources Chapter.  
 

2. Select the Resources tab. From the Edit menu in the toolbar, select Edit Resource.  

 
 

3. The Resource Details page displays. Proceed to the Resource Details section for additional instruction.  
 

 
 

4. From the File menu, select Save and Close Resource when complete. 
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Resource Details 
The Resources tab contains the demographic data on agencies and programs. If you are adding the resource record, the 
Resource Details page displays after selecting Add New. If you are editing the resource record, the Resource Details 
page displays after you select Edit Demographics from the Toolbar.  

1. The Resource Details page displays. Update any fields as needed.  

Field Use 
Basic Information  
Agency Key Number Select the PSA 
Resource Name Enter the name of the Resource 
Other Name (AKA) Enter any other names for the Resource 
Active A resource must be active to be visible in the Resource Directory 
Exclude from Selection A resource must not be excluded to be visible in the Resource Directory.  

The Department may exclude a resource from selection until they have 
finished the application process. 

Active/Inactive Comments Can be used by the Department to track progress through the 
application process and/or reason for inactivating. 

Year Started Enter the year if known 
Tax ID number Enter if ID number if known 
IRS Status Enter the status if known 
Overview Enter the overview of the agency or program 
Facility Type Select the facility type 
Agency Type Select the agency type 
Formal Update Used by the ADRCs to track the annual resource directory updates 
Email Broadcast Date Used by the ADRCs to track the annual resource directory updates 
Printed in Local Directory? Used by the ADRCs to track the annual resource directory updates 
Include in Website? Used by the ADRCs to track the annual resource directory updates 
Intake Procedure Select the intake procedure if known 
Contact Address  
Street Enter the street address 
Street 2 Enter the suite, apartment number, etc. 
City Enter the city 
State Enter FL 
Zip Code Enter the zip code 
Phone Enter the best contact phone number 
Email Enter the email 
Website Enter the website of the agency or program 
Mailing Address  
Mailing Address Same as 
Contact Address 

Use this shortcut if the mailing address it the same as the Contact 
Address. The application will copy it over. 

Mailing Name If a different agency/program name is used for the mailing address, 
enter it here 

http://wellsky.com/
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Mailing Contact Name Enter the name of the contact person if known 
Mailing Street Enter the street address 
Mailing Street 2 Enter the suite, apartment number, etc. 
Mailing City Enter the city 
Mailing State Enter FL 
Mailing Zip Code Enter the zip code 
 

2. When finished, from the File menu, select Save or Save and Close Resource. 
 

3. Contact and Mailing address are the most common resource addresses, so they are accessible on the Resource 
Details page. Adding them on the Resource Details page also adds them to the Addresses subpage, one record 
per address. If there are additional addresses besides Contact and Mailing that need to be added, they are 
added on the Addresses subpage.  
 

4. Contact (Physical) phone is the most common resource phone number so it is accessible on the Resource Details 
page. Add it to the Resource Details page also adds it to the Telephone Numbers subpage, one record per phone 
number. If there are additional phone numbers besides Contact (Physical) phone that needs to be added, it is 
added on the Telephone Numbers subpage.  

Resource Addresses 
Resource addresses will appear on the resource details page and on the addresses subpage. There can be several 
addresses for each of the Contact, Mailing and Correspondence types. There can be one address type selected as 
primary which will then display on the main resource page under the specific section for that address type.  

1. Open the resource record. Select the Resources tab. 
 

2. Select File > Edit Resource. The Resource detail page opens. 
 

3. Select Addresses from the left-hand navigation menu.  

 

4. The Addresses list view page opens. Existing addresses are shown in the list view grid. To edit an existing 
address, select it from the list view grid. 
 

5. To add a new address, from the File menu, select Add Address. 

http://wellsky.com/
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6. The Address details page displays.  

 
 

7. Update the following fields: 

 
 
 

Note: In order for the address to appear on the Resource detail page the Address Type 
must be Contact or Mailing and the record must be marked as the primary address and 
active.  

 

Field Use 
Address Type Select Contact, Mailing or Correspondence.  
Primary Check this box if the address should also display on the Resource Details 

page. Address Type must be Contact or Mailing and the address record 
must also be active. 

Street Enter the street address 
Street 2 Enter the suite, apartment number, etc. 
City Enter the city 
State Enter FL 
Zip Code Enter the zip code 
Start Date Enter a start/effective date for this address 
End Date Leave this field blank unless you are inactivating an address record. You 

would enter an end date and uncheck the Active checkbox. 
Active Check this box if the address should also display on the Resource Details 

page. Address Type must be Contact or Mailing and the address record 
must also be marked as primary.  

Comments Enter if needed 
 

8. Select File > Save and Close Address when complete.  

http://wellsky.com/
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Resource Telephone Numbers 
Resource phone numbers will appear on the resource details page and on the telephone numbers subpage. There can 
be several numbers for each of the Contact, Mailing and Correspondence types. There can be one address type selected 
as primary which will then display on the main resource page under the specific section for that address type 

1. Open the resource record. Select the Resources tab. 
 

2. Select File > Edit Resource. The Resource details page open. 
 

3. To add a phone number via the Telephone Number(s) subpage, select Telephone Number(s) from the left-hand 
navigation. The Telephone Numbers list view page opens. Phone numbers added via the detail page will be 
displayed in the list view. To edit a phone number, select it from the list view.  

 

4. To add a phone number, select File > Add Telephone Number. 
 

5. The Telephone Number page displays.  

 

6. Update the following fields:  

Field Use 
Phone Type Select a phone type for the number you’re adding 

http://wellsky.com/
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Phone Enter the phone number in (xxx)xxx-xxxx format 
Extension Enter the extension if known 
Start Date Enter the start date for this phone record. 
End Date Leave blank unless you are inactivating an old phone number. 
Active Needs to be checked unless you are inactivating an old phone number. 
Primary Needs to be checked if the Phone Type is ____  and this number should 

display on the Resource Details page. 
Comments Enter if needed. 
 

7. Select File > Save and Close Telephone Number when finished. 
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Division 
When a new resource record is created and the details page is saved, eCIRTS automatically opens the Division details 
page.  All resources must have an open Division record before their Resource record can be created in eCIRTS. Once the 
Division record is created, it does not need to be changed, unless the Resource record needs to be closed.  

 
1. For new resources, the Division details page opens when the Resource Details page is saved. Skip to step 3 to 

finish adding the Division record. Only the Department will be adding new resources and adding Division records 
to eCIRTS. 

 
2. The Department may need to inactivate a resource. In those cases, the existing Division record will be 

closed. From the Resource record, navigate to the Divisions tab and select the record from the list.  

 
 

3. The Division Details page opens.  Update the following fields: 

Field Use 
Division All Resources will be associated with AG 
Status Select Open when creating a new Resource record. 

Select Pending when the Resource is still going through the application 
process. 
Select Closed when inactivating a Resource record. 

Status Date Enter the date the status was selected or changed 
Open Date Enter the start/open date for the Resource 

 

 

4. From the File menu, select Save and Close Division. 
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Contacts - Workers 
The Workers tab contains information about contacts for the resource. Contacts for the agency or program are added as 
workers in eCIRTS. i.e. Site Director, Program Director, Contact Person. Resource workers will be added into eCIRTS via 
the initial data conversion.  If the Resource needs a new worker added after go live, the Department or PSA designees 
will follow the steps outlined below. 

1. To view the Workers tab, open the Resource record and select the Workers tab. Existing worker records, if any, 
are shown in the list view grid. 

 
 

2. Before you can add a new worker record, you must conduct a search to make sure that the worker doesn’t 
already exist. This helps to prevent duplicate records.  
 

3. Use the eCIRTS Admin or ADRC Records Management role to add a worker to the Resource record. 
 

4. Search for and select the Resource record and select the Workers tab. 
 

5. Select File > Add New Worker Search. The Worker Search page opens. 
 

6. Enter in the Search criteria and click Search. 
 

7. If a match is found, select it from the list view grid.  The Worker record opens and information can be updated 
before attaching to the resource. Skip to step 9.   

 
 

8. If a match is not found, add a new worker record by selecting Add New.  

http://wellsky.com/
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9. The Worker page opens. Update the following fields: 

 
 
 

Note: Any information you entered in the worker search filter will pre-populate in the 
worker detail screen.   

 

Field Use 
Member ID This will auto populate after the record is saved. Each worker record 

receives a unique eCIRTS ID number. 
Worker Type Select a worker type 
Last Name Enter or update the last name 
First Name Enter or update the first name 
Title Enter the contact’s title 
Phone Enter the phone number (xxx)xxx-xxxx format 
Extension Enter the extension if known 
Email Enter the email if known 
Fax Number Enter the fax number if known (xxx)xxx-xxxx format 
Start Date Effective dates can be added for workers. Enter the start date 
End Date Can leave blank unless the worker is being inactivated. 
Active To deactivate a worker, clear the “Active” option.  Inactive workers are 

automatically not included in the worker dropdown lists throughout 
eCIRTS.  If the worker is associated with multiple resources when the 
record is deactivated the worker will be inactive for all resources.  
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10. Select File > Save and Close Worker when done. An eCIRTS generated Member ID has been assigned to this 
worker. The worker has been added to the Resource record. 

Service Area 
The Service Areas tab is contains information about what areas the resource serves in the community. Resources also 
have service-specific service areas. A master Service Area record must exist for the Resource first before service-specific 
service areas can be added.  

1. Open the Resource record and select the Service Areas tab. Each resource will have a single service area record. 

 
 

2. To edit an existing Service Area, from the File menu, select Edit Service Area.  

 
 

3. To add a new Service Area, from the File menu, select Add Service Area.  
 

4. The Service Area page displays. Select or update the service area. Select the values in the left-hand box and 
move them to the right-hand box using the arrows.  
 
 
 
 

Note:   
Select the most specific level of service area first and the application will populate 
other details. Do not go top down. For example, when you select the zip code, the 
application will populate the appropriate state, region, county, and city fields. 
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Note:   
To select multiple values, press CTRL while you select the values you want to apply. 
Use the arrow button to move the value from the left box to the right box. 
• The double right arrow button will move all value from the left to right 
• The single right arrow button will move selected values from left to right 
• The single left arrow button will move all values from right to left 
• The double left arrow button will move selected values from right to left 

 
5. From the File menu, select Save and Close Service Areas when done. 
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Services/Taxonomy 
The Services tab is where you can record the services, by Taxonomy code, that an agency or program would offer to the 
community. The Service/Taxonomy must exist first in the Service Codes Utility, managed by BIT, and then it can be 
associated with a Resource by the Department or PSA staff. A service/taxonomy must be added to a resource before it 
will be visible in the Resource Directory for the Helpline staff. 

 
 
 

Note: The Service codes must be set up in the Service Code Setup Utility before you 
can add a service to a resource. For assistance, please contact your System 
Administrator.  

 

Add or Edit a Service/Taxonomy 
1. Open the Resource record and select the Services tab. 

 
2. If you are editing a Service/Taxonomy select a record from the list.  

 
3. If you adding a new Service/Taxonomy, from the File menu, select Add Services. 

 
4. The Service/Taxonomy page will open in a new window.  Update the following fields: 

Field Use 
Service ID Search for and select the service/taxonomy. See the Search tips section 

below. 
Billable Do not check this box 
Active This must be checked for the service to be visible for the resource in the 

Resource Directory. 
Active Date Enter a start/active date 
End Date Active service/taxonomy codes do not need an end date.  

Enter an end date when you are inactivating a service/taxonomy record 
for a resource. 

Taxonomy Code auto populates when you select the Service ID 
Taxonomy Term/Service auto populates when you select the Service ID 

Secondary Code This defaults as the Taxonomy code and does not need to be changed 
Taxonomy Category Enter the AIRS Problem Need. This field will change to a lookup field 

after Phase 1 go live. 
Service 
Description/Guidelines 

Enter the service description or any agency/program guidelines. 

Hours Hours are visible in the Service Description/Guidelines field for Phase 1. 
In Phase 2 they will be housed in a separate field.  

Program Name(s) A resource can have several Program Names. Program name is 
frequently used in the Resource directory search by the Helpline staff. 
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Payment Options/Eligibility This used to be 2 fields in CIRTS and text fields. In eCIRTS, the fields are 
combined and multiple options can be selected 

Resource Service Areas Allow This box defaults to checked and should remain checked when the 
Resource record is created.  

Later when the PSA’s update the Resource record, they will uncheck this 
box in order to add service specific service areas.  

Unit Cost Enter zero. This is an eCIRTS required field but doesn’t have any 
functionality for Resources. If you do not add a value in this field, will get 
an error message when saving the page. 

 
 

5. When finished, from the File menu, select Save and Close Taxonomy.  
 

6. Once the service record is saved, the Areas Served subpage is displayed but is not editable. The PSA will update 
the Area Served later in the workflow. The update will be made from the Taxonomy/Service page but changes 
will be visible on the Area Served subpage.  
 

Search Tips 
1. Search by Service Type to filter the list by Service Category from REFER 
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2. Search by Service Category to filter the list by Sub-Category/Service Group from REFER  

 

3. Search by Service to filter the list by Taxonomy Term from REFER. 
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Service-Specific Service Area 
Service areas are the locations in which a specific service is offered by the Resource. By default, services use the resource’s 
service area location, which is recorded in the resource Service Areas tab. If you are setting up a service that will be offered 
in a different, or more limited service area, clear the “Resource Service Areas Allow” field and then save the more specific 
service area.  

 

 
 
 

Note: Add the service area record under the Services page creates an additional record 
that is associated with the specific service and does not affect the Service Areas record 
under the Service Areas tab in the main resource record.   

  

1. Search for and select the Resource.  
 

2. Select the Services tab and select the Taxonomy/Service that needs the Service area.  
 

3. Uncheck the “Resource Service Areas Allow” field.  
 

4. A prompt will display asking if you want to add a Service Area. Select Yes.  

 
  

5. The Areas Served page displays. By default, the State, County, City and Zip Code selected on the Resource > 
Service Area tab is populated.  
 

6. Update the service area specific to this service. Select the values in the left-hand box and move them to the 
right-hand box using the arrows.  

http://wellsky.com/
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Note:   
Select the most specific level of service area first and the application will populate 
other details. Do not go top down. For example, when you select the zip code, the 
application will populate the appropriate state, region, county, and city fields. 

 
 
 
 
 

Note:   
To select multiple values, press CTRL while you select the values you want to apply. 
Use the arrow button to move the value from the left box to the right box. 
• The double right arrow button will move all value from the left to right 
• The single right arrow button will move selected values from left to right 
• The single left arrow button will move all values from right to left 
• The double left arrow button will move selected values from right to left 

 
7. From the File menu, select Save and Close Area Served when done.  

 
8. You are returned to the Taxonomy/Services page. From the File menu, select Save Taxonomy/Service or Save 

and Close/Taxonomy Service. 
 

9. The service specific service area is visible on the Area Served subpage.  
 

10. If you need to edit the service specific service area, select the Area Served subpage and update the values. As 
long as the “Resource Service Areas Allow” field is blank on the services page, the Area served can be edited for 
the service.  
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Conditions 
The Conditions tab stores additional resource characteristics such as languages spoken, payment options, accessibility, 
and age and gender restrictions. This information helps users find an agency or program that offers the appropriate 
service. For example, not all agencies accept both male and female patients. 

1. To add a new condition, use the eCIRTS Admin or ADRC Records Management role.  
 

2. Search for and select the Resource record. Select the Conditions tab. 
 

3. Each resource can have one Conditions record. If it already exists and needs to be updated, select Edit 
Conditions from the File menu.  

 
 

4. If a condition record needs to be added, from the File menu, select Add Conditions. 

 
 

5. The Conditions detail page displays. Select the values in the left-hand box and move them to the right-hand box 
using the arrows.  

Field Use 
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Accessibility Select all values that apply to this resource. 
Mission Enter a mission if available for this resource. 
Languages Spoken  Enter the languages spoken by the resource. This will be a text field for 

Phase 1 and change to a multi-select lookup (like the screenshot below) in 
Phase 2. 

Notes Note about the resource go into this field.  
Females Served Check this box if the resource serves females. 
Minimum Age Females Enter the minimum age served. 
Maximum Age Females Enter the maximum age served. 
Males Served Check this box if the resource serves males. 
Minimum Age Males Enter the minimum age served. 
Maximum Age Males Enter the maximum age served. 
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Note:   
To select multiple values, press CTRL while you select the values you want 
to apply. Use the arrow button to move the value from the left box to the 
right box. 
• The double right arrow button will move all value from the left to right 
• The single right arrow button will move selected values from left to 

right 
• The single left arrow button will move all values from right to left 
• The double left arrow button will move selected values from right to 

left 
 

6. When finished, from the File menu, select Save and Close Conditions. 
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Linked Resources 
The Linked Resources tab shows the relationship between a parent agency and subsidiaries. The subsidiaries are known 
as child resources. You can edit the parent information without applying those changes to the child resource. You can 
also edit the child information without applying those changes to the parent resource. 

1. Use the eCIRTS Admin or ADRC Records Management role to add a linked resource.  
 

2. Search for and select the parent resource record. Select the Linked Resources tab. 
 

3. If a linked resource relationship exists, it is shown in the list view grid. If you need to edit an existing linked 
relationship, select it from the list and skip to step 5. 

 
 

4. To add a new linked resource, from the File menu, select Link to a Vendor.  

 
 
 

Note:   
Resources, Providers and Agencies are all considered “Vendor” records in eCIRTS 

 

  
 

5. The Link a Resource page displays. Update the following fields: 

Field Use 
Relationship Since you are starting on the parent record, select Child as the relationship 

of the resource you are going to link. 
Resource Search for and select the child resource.  
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Start Date Enter a start date for the linked relationship 
End Date This field can remain blank unless you are ending a linked relationship. 

 

 

 
 
 

Note:   
The Resource field uses the resource search popup. Select a search parameter from 
the Search By dropdown and then type your search criteria in the Search Text entry 
bar.  Click Search. Results are returned. Click to select the Child resource from the 
popup window. The search popup closes, and the name of the child resource displays 
in the Resource field on the Linked Resources page. 

 
 

6. From the File menu, select Save and Close or use the shortcut, Save and Add Another if you have another 
resource to link to this parent resource.  

Unlink a Resource 
1. Use the eCIRTS Admin or ADRC Records Management role to unlink a child resource from the parent.  

 
2. Open the Resource record and select the Linked Resources tab.  

 
3. Use the checkbox next to the child resource’s name in the list view grid to select the linked resource. 

 
4. From the File menu, select Unlink Linked Resources. 
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5. A confirmation message appears. Click OK to continue.  

 
 

6. The record will be unlinked and will be removed from the list view grid. A second confirmation message appears. 
Click OK. 

 

7. The unlinked resource is no longer visible on the Linked Resources list view. 
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