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Icons used in the Guide 
Icon Description 

 
 
 

Tip 

Tips provide general recommendations on how to make it easier or more productive to use 
WellSky. 

 

Caution 

The Caution icon highlights areas of note or concern, where failure to use the system properly 
may cause or exacerbate problems. 

 

Note 

Notes provide additional information of general interest about a specific function or process of 
WellSky. 

 

Example 

Examples are provided to help you develop a better understanding of the subject area and how 
WellSky may be used in a specific scenario of relevance. 
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Eligibility Workflows Training Guide Overview & Objectives 
WellSky Human Services application/eCIRTS will maintain the helpline, intake/screening and eligibility process 
throughout the state of Florida, previously completed in REFER and CIRTS.  

Introduction  This training introduces you to the workflows completed by the eligibility  
staff in eCIRTS. 

Importance  Your confidence in using eCIRTS for receiving caseload assignments, 
documenting contact attempts, completing pre-release research tasks, 
creating the Medicaid Waiver Timeline form, and creating CARES referrals 
will increase as you develop proficiency in the software. 

Overview  To help develop the necessary skills and understanding to effectively use 
eCIRTS to perform the eligibility workflows.  

Objectives  Following the steps in the guide to: 

• Assign eligibility specialists to a case. 

• Receive new caseload assignments. 

• Document contact attempts. 

• Document the completion of pre-release research tasks. 

• Create and update Medicaid Waiver Timeline forms. 

• Create the CARES Referral. 
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Eligibility specialists can receive any of the following types of referrals:  
1. EMS Release 
2. APS to ALF referral 
3. Regaining eligibility referral 

 

EMS Release 
Most of the cases assigned to eligibility specialists are an EMS release. Once AHCA provides the number of slots 
for release and the EMS Release Date, the interface will populate it on the client’s Demographic record in 
eCIRTS. The date does NOT need to be manually added but you can view it.  

 

Role: eCIRTS Worker 

1. Navigate to the Client record and select the Demographics tab.  
 

2. The EMS Release Date is visible at the top of the page and within the Demographic summary section 
about halfway down the page.  

 
 

Eligibility Specialist Assigned 
Once the EMS release date is received from AHCA, the ADRC supervisor or designee will assign each client to an 
Eligibility Specialist.  
 

 

Role: eCIRTS Worker 

1. Use EMS Release Report or use the My Work > Waitlist queue filters to determine Eligibility Specialist 

assignments. Navigate to My Work.  

 

2. Select the Tasks > My Management > Wait List queue.  
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3. Enter the following search filters: 

a. Program: contains MLTC 

b. Status: begins with APCL 

c. Enrollment Provider: search for and select the generic Default PSA worker record for your PSA 

knowing the MLTC waitlist enrollments are assigned first to this ‘queue’ then assigned to an 

eligibility specialist. 

d. EMS Release Date: not blank 

 
 

4. Click Search. MLTC records in APCL status in your PSA that need to be assigned to an eligibility specialist 

are listed. Note Primary Language and Other Language are visible in the search results. These can help 

the assignment process.  
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5. Each client will be assigned to an eligibility specialist by changing the Enrollment Provider on the MLTC 

program record.  From the Wait List search results, select the View Consumer link. This will open the 

full client record. Select the MLTC APCL record from the Programs tab. 

 
 

6. If you only need to edit the MLTC program record, you can just click it from the Wait List search results 

list. The Program details page displays. 

 
 

7. Select the Enrollment Provider subpage. Any worker ever associated with this enrollment will be listed. 

Add the eligibility specialist. From the File menu, select Assign Enrollment Provider.  
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8. Search for and select the name of the assigned eligibility specialist.  

 
 

9. The page refreshes and the name is populated. Update the following fields: 

a. Start Date: default to today. Can be backdated if needed. 

b. End Date: leave blank. Can be added if/when this worker is no longer active with this case. 

c. Primary: Check the box. Only one worker can be Primary, and you want it to be the eligibility 

specialist. The Primary worker is the one who will be able to see this client on their My Work 

queues.  

d. Active: check the box 

 
 

10. From the File menu, select Save and Close Enrollment Provider. 

 

11. The eligibility specialist will access his/her caseload on My Work.  Proceed to the View Caseload 

section. 

 

View Caseload 
The eligibility specialist can use the queues on My Work to view and manage their caseload as the client’s 

progress through the EMS release, CARES Assessment, LOC determination and eligibility process.  

 
Role: eCIRTS Worker 
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To view newly assigned cases: 
1. Navigate to My Work.  Select the Clients > Programs queue.  

 
 

2. New cases that have been assigned to the eligibility specialist will be visible by selecting the APCL 

Waitlist queue. 

 
 

3. Each assigned case will need to be contacted to confirm the client’s interest. Pre-research release tasks 

must also be completed. The PSA will determine which should come first but both must be completed 

before the MLTC record can go into APPL status and the CARES referral made.  Proceed to the following 

sections: 

a. Contact Attempts 

b. Pre-release Research Tasks 

 

To view cases referred to CARES awaiting LOC:  
1. Navigate to My Work.  Select the Clients > Programs queue.  
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2. Cases that have been referred to CARES and are awaiting LOC will be visible by selecting the APPL 

Applicant. Other cases in APPL Applicant status will also be visible in this queue.  

 
 

Contact Attempts 
Eligibility specialists will make up to 3 contact attempts to reach the client and confirm their interest before 
making the CARES referral.  Each contact attempt will be documented on a separate Contact record in eCIRTS.  
For some PSAs this step happens before the Pre-Release Research tasks. For other PSAs, the Pre-Release 
Research tasks come first. Regardless of the order, the steps to complete in eCIRTS are the same and both must 
be completed before making the CARES referral. 
 
It’s best practice to view past contacts before reaching out to a client. Also be prepared to update the client’s 
demographic information as needed. See the As Needed: View Contact Information section. 
 

 
Role: eCIRTS Worker 

 

Add Contact Record  
The contact record houses the details of a call/contact attempt. A contact record can be added directly from a 
shortcut on the client search or a shortcut on the client > Demographic page. 
 

 
Role: eCIRTS Worker 

 
1. The eligibility specialist will first search for the existing client record.  
 
2. From the existing client search results, select the flyout menu to the right of the client’s name in 

the search results. Select Add Contacts. The Contact Details page displays. 
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3. Or, with the client record already open, select the Demographics tab. From the File menu, select 
Add Contact. The Contact Details page displays. 

 
 
 
4. The Contact details page displays. Update the following fields: 

a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: Required. defines how the contact was made. 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: search field. If the Caller already exists on the client's Associated 

People tab, their name will be listed, and the eligibility specialist can pick it from the list to 
populate the field.  
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If not, the eligibility specialist can close the search window by clicking the X at the top right and 
just type the name into the "Caller if other than client" box on the contact screen.  

 
n. REMINDER!: ADD ASSOCIATED PEOPLE RECORD FOR CALLER. This message displays when a 

value is added to the Caller if Other than Client field. 

 
o. Relationship: enter the relationship of the caller to the client 
p. Contact Type: select SMMC LTCP – Eligibility  
q. Short Summary: leave blank. Will be updated later in the workflow.  
r. Notes: leave blank. Will be updated later in the workflow. 
s. Contact Marker: leave blank. 
t. SNAP Submittal Date: leave blank. 
u. Reason for Contact: leave blank. Will be updated later in the workflow. 
v. Referral Type: leave blank. 
w. 701S Appointment Date: leave blank.  
x. Unmet Needs Reason: leave blank. 
y. Assigned To: see next sections.  
z. Screener: leave blank 
aa. Contact Status: can remain Draft. Will be updated later in the workflow.  
bb. Duration: will automatically populate after the record is saved. 
cc. Client Primary Language: leave blank. This field is used when the screening referral from the 

Helpline is created.  
dd. Other Language: leave blank. This field is used when the screening referral from the Helpline is 

created.  
ee. Follow Up Date: leave blank.  
ff. Screening Referral Created Date: leave blank. 

 
5. From the File menu, select Save Contact. 

 
6. Proceed to one of the following scenarios:  

a. Unsuccessful Contact 1 
b. Unsuccessful Contact 2 
c. Unsuccessful Contact 3 
d. Successful Contact – Client Not Interested 
e. Successful Contact – Client Hospitalized/NH  
f. Successful Contact – Client Confirms Interest  
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Unsuccessful Contact 1 
An unsuccessful contact is when a contact attempt is made, and the worker does not speak with the 
caller/client. The worker will make up to 3 contact attempts, all documented in separate eCIRTS Contact 
records. This section includes steps to document the first unsuccessful contact attempt. 
 

 
Role: eCIRTS Worker 

 
1. With the contact details page open, update the following fields to complete this contact record:  

a. Short Summary: brief details about the unsuccessful attempt. Should be limited to 2-3 
sentences. This field is visible on the Contact queue. 

b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

c. Contact Type: remains SMMC LTCP - Eligibility 
d. Reason for Contact: Waitlist Release - Attempt 1  
e. Contact Status: update to Complete.  
f. Assigned To: search for and select your own name if not already selected. 

 
2. From the File menu, select Save and Close Contact. 

 
3. When a contact record is saved with Contact Type = SMMC LTCP – Eligibility and Contact Status = 

Complete and Reason for Contact = Waitlist Release - Attempt 1, eCIRTS will automatically create a 

second contact record to track the second contact attempt. The eligibility specialist will filter the 

Contacts queue to view and manage contact attempts that require follow up.  Proceed to the Follow 

Up section. 

 

Unsuccessful Contact 2 
This section includes steps to document the second unsuccessful contact attempt.  
 

 
Role: eCIRTS Worker 

 
1. With the contact details page open, update the following fields to complete this contact record:  

a. Short Summary: brief details about the unsuccessful attempt. Should be limited to 2-3 
sentences. This field is visible on the Contact queue. 

b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

c. Contact Type: remains SMMC LTCP - Eligibility 
d. Reason for Contact: Waitlist Release - Attempt 2  
e. Contact Status: update to Complete.  
f. Assigned To: search for and select your own name if not already selected. 

 
2. From the File menu, select Save and Close Contact. 

 

3. When a contact record is saved with Contact Type = SMMC LTCP – Eligibility and Contact Status = 

Complete and Reason for Contact = Waitlist Release - Attempt 2, eCIRTS will automatically create a 

second contact record to track the second contact attempt. The eligibility specialist will filter the 
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Contacts queue to view and manage contact attempts that require follow up.  Proceed to the Follow 

Up section. 

 

Unsuccessful Contact 3 
This section includes steps to document the third unsuccessful contact attempt and close the case.  
 

 
Role: eCIRTS Worker 

 

1. With the contact details page open, update the following fields to complete this contact record:  
a. Short Summary: brief details about the unsuccessful attempt and closing of the MLTC 

enrollment. Should be limited to 2-3 sentences. This field is visible on the Contact queue. 
b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 

and only needed if additional details are needed beyond the Short Summary 
c. Contact Type: remains SMMC LTCP - Eligibility 
d. Reason for Contact: Waitlist Release - Attempt 3  
e. Contact Status: update to Complete.  
f. Assigned To: search for and select your own name if not already selected. 

 
2. From the File menu, select Save and Close Contact. 

 
3. When a contact record is saved with Contact Type = SMMC LTCP – Eligibility and Contact Status = 

Complete and Reason for Contact = Waitlist Release – Attempt 3, eCIRTS will NOT automatically create 

an additional contact record.     

 
4. The eligibility specialist will also close the MLTC program record. From the open client record, select 

the Programs tab. A list of program enrollments is displayed. Select the MLTC program record in APCL 
status. Update the following fields: 

a. Status: Terminate – APCL Waitlist 
b. Termination Reason: Lost Contact 
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5. From the File menu, select Save Programs.  Do NOT select Save and Close Programs.  
 

6. Select the Enrollment Provider subpage. Changing the enrollment provider from yourself back to the 
generic Default PSA provider for your PSA will remove this client from your caseload and it will no 
longer be visible on your My Work page. For those PSAs who honor the Return to Pipeline – 6 month 
period, this step might not be completed right away as the eligibility specialist will remain assigned to 
the case for the 6 month waiting period in case the client re-engages.  
 

7. When this does need to be completed, complete the following steps to change the Primary designation 
from yourself to the generic Default PSA worker for your PSA. From the Enrollment Provider subpage. 
Select the Default PSA Worker record for your PSA.  

 
 

8. The Enrollment Provider details page displays. Update the following fields: 
a. Primary: check the box 
b. End Date: enter the date you are making the change. 
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9. From the File menu, select Save and Close Enrollment Provider. 
 

10. If the client reaches out within 6 months of closing the MLTC record, proceed to the Return to Pipeline 
section. 
 

Successful Contact – Client Not Interested 
This workflow should be used when a contact attempt is made, and the client is reached but has decided NOT 
to pursue services.  
 

 
Role: eCIRTS Worker 

 
1. With the contact details page open, update the following fields to complete this contact record:  

a. Short Summary: Note the client was not interested. Should be limited to 2-3 sentences. This 
field is visible on the Contact queue. 

b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

c. Contact Type: remains SMMC LTCP – Eligibility 
d. Reason for Contact: Waitlist Release  
e. Contact Status: update to Complete.  
f. Assigned To: defaults to self. Can remove value or leave as is. 

 
2. From the File menu, select Save and Close Contact.  

 
3. The eligibility specialist will also close the MLTC program record. From the open client record, select 

the Programs tab. A list of program enrollments is displayed. Select the MLTC program record in APCL 
status. Update the following fields: 

a. Status: Terminate – APCL Waitlist 
b. Termination Reason: By Client 
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4. From the File menu, select Save Programs.  Do NOT select Save and Close Programs.  
 

5. Select the Enrollment Provider subpage. Changing the enrollment provider from yourself back to the 
generic Default PSA provider for your PSA will remove this client from your caseload and it will no 
longer be visible on your My Work page.  Select the Default PSA Worker record for your PSA.  

 
 

6. The Enrollment Provider details page displays. Update the following fields: 
a. Primary: check the box 
b. End Date: enter the date you are making the change. 
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7. From the File menu, select Save and Close Enrollment Provider 
 

Successful Contact – Client Hospitalized/Nursing Home 
This workflow should be used when the client has been hospitalized or placed in a nursing home and wants to 
continue the eligibility process.   
 

 
Role: eCIRTS Worker 

 
1. With the contact details page open, update the following fields to complete this contact record:  

a. Short Summary: Note the client was hospitalized or placed in a nursing home. Should be 
limited to 2-3 sentences. This field is visible on the Contact queue. 

b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

c. Contact Type: remains SMMC LTCP – Eligibility 
d. Reason for Contact: Waitlist Release  
e. Contact Status: update to Complete.  
f. Assigned To: defaults to self. Can remove value or leave as is. 

 
2. From the File menu, select Save and Close Contact.  

 
3. The eligibility specialist will also close the MLTC program record. From the open client record, select 

the Programs tab. A list of program enrollments is displayed. Select the MLTC program record in APCL 
status. Update the following fields: 

a. Status: Terminate – APCL Waitlist 
b. Termination Reason: Client Hospitalized or Placed in Nursing Home 
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4. From the File menu, select Save Programs.  Do NOT select Save and Close Programs.  
 

5. Select the Enrollment Provider subpage. Changing the enrollment provider from yourself back to the 
generic Default PSA provider for your PSA will remove this client from your caseload and it will no 
longer be visible on your My Work page. For those PSAs who honor the Return to Pipeline – 6-month 
period, this step might not be completed right away.   
 

6. When this does need to be completed, complete the following steps to change the Primary designation 
from yourself to the generic Default PSA worker for your PSA. From the Enrollment Provider subpage. 
Select the Default PSA Worker record for your PSA.  

 
 

7. The Enrollment Provider details page displays. Update the following fields: 
a. Primary: check the box 
b. End Date: enter the date you are making the change. 
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8. From the File menu, select Save and Close Enrollment Provider. 
 

9. If the client reaches out within 6 months of closing the MLTC record, proceed to the Return to Pipeline 
section. 

 

Successful Contact – Client Confirms Interest 
This section includes steps to document a successful contact and update the MLTC program record when the 
client confirms interest.  
 

 
Role: eCIRTS Worker 

 
1. With the contact details page open, update the following fields to complete this contact record:  

a. Short Summary: Note the client confirmed interest. Should be limited to 2-3 sentences. This 
field is visible on the Contact queue. 

b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

c. Contact Type: remains SMMC LTCP – Eligibility 
d. Reason for Contact: select Waitlist Release if this is the first contact attempt. Select Medicaid 

Eligibility if this is the second or third contact attempt. 
e. Contact Status: update to Complete.  
f. Assigned To: defaults to self. Can remove value or leave as is. 

 
2. From the File menu, select Save and Close Contact. 

 
3. The eligibility specialist will also update the MLTC program record. From the open client record, select 

the Programs tab. A list of program enrollments is displayed. Select the MLTC program record in APCL 
Waitlist status. Update the following fields: 

a. Status: APPL Applicant 
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4. From the File menu, select Save and Close Programs.  
 

5. You do NOT need to update the worker on the Enrollment Provider subpage. You want this client to 
remain visible on your My Work page so you can manage your caseload throughout the staffing process 
and level of care determination. The MLTC interface will change the enrollment provider from yourself 
to the MCO when the client is Medicaid active. 
 

6. Proceed to the Medicaid Waiver Timeline Form section. 
 

As Needed: View Contact Information 

In eCIRTS, all callers, except anonymous ones, will have a client record. Contact records will then be added to 
the client record. This workflow allows eligibility specialists to view past contact information in several ways in 
eCIRTS.  

1. The View Contacts list is an easily accessible list of the client’s past contacts because knowing the 
details of previous contacts may assist with the current contact.  

2. The Contacts Queue is a full list of all contacts that can be filtered down so eligibility specialists can 
manage their workloads and supervisors can oversee work.  

3. In addition to the queue, there is also a report that displays all past contacts for a client. The report can 
be run from any open contact record and will automatically display information on all past contacts for 
the client record you are on, without having to add any report filters. 

Workers also need to be prepared to review and update the client’s demographic information as needed.  

 

 

Role: eCIRTS Worker 

1. There are several ways to view previous contacts for a client. From the Clients chapter, from any tab on 
the client’s record, select View Contacts from the top menu bar.  
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2. A limited summary view of the client’s past contacts displays. This list does NOT display the Short 
Summary field from the contact record.  

 
 

3. Select a record for more information. The Contact record will open. If it is in complete status, all of the 
fields will be read only, but the information is still visible.  
 

4. When finished, the eligibility specialist can close the Contact record and close the View Contacts 
window. 
 

5. A more detailed list of previous contact information is available by selecting the Contacts chatper. A full 
list of previous contacts for all clients is available but too long to look through. The filters are essential 
to making this list managable and useful. Search by eCIRTS Client ID to display only the previous 
contacts for one client. 
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 TIP 

Saved filters are key. Be sure to take the time to create several saved filters specific to 
your day-to-day workload. 

6. Finally, if you have a contact record open, select Previous Contact Report from the Reports menu.   
 

7. The report displays all previous contact information for the client record you have opened.  
 

8. With the contact record still open, the worker should confirm the client’s Demographics and update as 
needed.  Since this workflow started on the client record, the worker can easily view the client’s 
demographic information on the Client subpage.  
 

9. Click on the record to view additional demographic data. You can see the data; you cannot edit it from 
this page. To open the client record where the Demographics can be updated, from the Tools menu, 
select "View Client." See the As Needed: Update Demographics section for details on editing this page. 
Once complete, return to the open Contact record.  

 
 

As Needed: Update Demographics 

You can edit Demographics from this same page. For existing clients, the Demographics summary page shows 
first and displays the most frequently referenced Demographic fields. There are more Demographics data 
elements to view but the user must select Edit Demographics from the File menu to view/edit them. 

 
Role: eCIRTS Worker  
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1. To edit or add demographic information or see additional Demographic information not displayed on 
the Demographic Summary page, select Edit Demographics from the Edit menu. The Demographic 
Details page displays. 

 
 

2. The Demographic Details page has several sections. The eCIRTS user may need to revisit this page 
several times to collect all the data from the client. The only required fields that must be completed 
before the Demographics page can be saved are First Name, Last Name, Date of Birth, Gender, Race, 
Ethnicity, County and PSA. 

Basic Demographics: 

a. EMS Release Date: AHCA provides the EMS Release Date for a set number of clients.  
b. Former CIRTS ID: the ID number for the client in the legacy CIRTS system 
c. First Name*: client’s first name 
d. Last Name*: client’s last name 
e. Middle Initial: client’s middle initial 
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f. AKA Name: alias name for the client if applicable 
g. Title: the client’s title 
h. Date of Birth*: client’s birthday 
i. DOB Unknown: use this field when the DOB is not known, and the DOB field will be hidden and 

no longer required. 
j. Age: client’s age 
k. Date of Death: client’s date of death, if applicable 
l. SSN: client’s social security number. The SSN in this field will populate in other places of the 

application like 701S and 701B assessments. 
 

 NOTE 

In March 2022, DOEA approved the change to mask SSN in eCIRTS to comply with 
requirements.  

Only users with the eCIRTS SSN Manager role can see a full SSN. All other users can 
only see the last 4 digits.  

Users can still search by full SSN in the Quick Search or use the Advanced Search to 
search by the last 4 digits.  

 

 NOTE 

Several roles can add SSN but only the eCIRTS SSN Manager role can unmask and 
edit the SSN. Only certain users will be given the eCIRTS SSN Manager role. The 
SSN can also be added/updated from the 701 Assessments. The SSN saved on 
assessments will also update the SSN on the Demographics page. 

 

m. Pseudo SSN: Pseudo SSN for the client when a real SSN is not known. The Pseudo SSN does not 
populate on the 701B assessment.  

n. Medicaid Number: Medicaid number of the client if applicable 
o. Gender*: client’s gender 
p. Marital Status: the marital status of the client 
q. Head of Home: Check if Yes. Leave blank if No. 
r. Disabled: NAPIS/OAAPS required field that pulls from the Assessment 
s. Are you a veteran?: Yes or No 
t. Veteran Status: If Are you a Veteran is equal to Yes, then answer this question. 
u. Do you have Adult Cystic Fibrosis?: Yes or No 
v. Primary Race*: client’s race.  
w. Additional Race: Multi select field to record additional race. 
x. Ethnicity*: client’s ethnicity  
y. Primary Language: The primary language of the client 
z. Other Language: Use this field to record other languages for the client. 
aa. Other Communication Method: Other communication method used by the client. 
bb. Interpreter Service Used?: Check this box if services were used. This will be tracked for 

invoicing purposes. 
cc. Client has limited ability reading, writing, speaking or understanding English: Yes or No 
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Contact Information: 

a. Homeless?: Yes or No 
b. Address Type: Defaults to Physical. The physical address should the primary address. Home 

and Mailing address can be added under the Client Address subpage.   
c. Address Category: When Address Type is Physical, this field is visible and required.  
d. Facility Name: Enter the facility name when applicable. 
e. Street: Enter the street address 
f. Street 2: Enter the street address. 
g. City: Enter the city 
h. State: The places list presents a list of values based on the city selected. 
i. Zip Code: The places list presents a list of values based on the city, state selected. 
j. County*: The places list presents a list of values based on the city, state, zip selected. 
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Note 

Several reports use the client’s county to display results so be sure to enter this field.  

 
k. PSA*: The places list presents a list of values based on the city, state, zip, county selected.  

 

Note 

Several reports use the client’s PSA to display results so be sure to enter this field. 

 
l. Agency: This field is populated by the places list with the Agency name.  

 

Note 

Several reports and behind the scenes automations use the full Agency Name in this 
field. Be sure to enter this field.   

m. Best Contact: The best number to reach the Client. This could be the Home, Work or Mobile 
phone number. 

n. Phone Note: description of the Best Contact number (i.e. sister, caregiver) 
o. Home Phone:  The home phone number of the Client. 
p. Work Phone: The work phone number of the Client.  
q. Work Extension:  The work phone number extension of the Client.  
r. Mobile Phone: The mobile or cell phone number of the Client. 
s. Email: The email address of the Client. 
t. Address Note: This field is used for notes about the address. It was added so users would 

record real USPS address information in the street fields instead of notes. 
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Additional Information: 

a. Rank: The Priority rank from the most recent assessment and is updated every time a 701S, 
701A or 701B is saved. It is read only. 

b. Priority Score: The Priority score from the most recent assessment is updated every time a 
701S, 701A or 701B is saved. It is read only. 

c. Assessment Date: The date of the most recent assessment is updated every time a 701S, 701A 
or 701B is saved. It is read only.  

d. Eligible for SS Disability: Answer Yes or No. 
e. Is Rural?: OAAPS required field that is populated automatically based on the zip code in the 

Places List.  
f. Lives Alone?: OAAPS required field that pulls from the Assessment. 
g. In Poverty?: OAAPS required field that pulls from the Assessment. 
h. NSIP Meal Eligible: OAAPS required field that pulls from the Assessment. 
i. NSIP Eligibility Type: OAAPS required field that pulls from the Assessment. 
j. Below 150% Poverty Level: OAAPS required field that pulls from the Assessment. 
k. High Nutrition Risk: OAAPS required field that pulls from the Assessment. 
l. Cognitive Impairment: OAAPS required field that pulls from the Assessment. 
m. ADL Score: OAAPS required field that pulls from the Assessment.  
n. IADL Score: OAAPS required field that pulls from the Assessment. 
o. CoPay: Populate this field for client’s who have a copay 

 
 

3. When finished, from the File menu, select Save and Close Demographics.  
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Note 

SSN, DOB, Rank, Priority Score, Assessment Date and EMS Release Date from the 
Demographics page are also visible in the header that remains visible on any tab of the Client 
record. As data for these fields changes on Demographics, it will also change in the header.  

 
 

4. A workflow wizard triggers a tickler when street is added or edited on the Demographics page. The 
tickler is to add a second address, either Mailing or Home. The tickler lands the user on the Client 
Address details page. Proceed to step 6 of the Client Address section.  

 

 
 

5. If you are editing the address and already have a second address, the tickler can be cancelled. From the 
tickler flyout menu, select Cancel. 

 
 

Client Address 
The Demographics page houses many data elements including one primary address. If a client has multiple 
addresses, they are recorded on the Client Address subpage. Only the primary address is visible on the 
Demographics page. 
 

 
Role: eCIRTS Worker 

 
1. Navigate to the client’s record and select the Demographics tab. 
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2. From the File menu, select Edit Demographics. 
 

3. The Demographics detail page displays. The Client Addresses and Client Phone subpages are listed on 
the left.  
 

4. Select the Client Address subpage. The address visible on the demographics detail page, the primary 
active address, will also be visible on this subpage.  
 

5. To add an additional address, from the File menu, select Add Client Address. 
 

6. The Address Details page displays. Update the following fields: 
a. Address Type: Defaults to Physical. The physical address should the primary address. Home and 

Mailing address can be added under the Client Address subpage.   
b. Address Category: When Address Type is Physical, this field is visible and required.  
c. Facility Name: Enter the facility name when applicable. 
d. Street: Enter the street address 
e. Street 2: Enter the street address. 
f. City: Enter the city 
g. State: The places list presents a list of values based on the city selected. 
h. Zip Code: The places list presents a list of values based on the city, state selected. 
i. County*: The places list presents a list of values based on the city, state, zip selected. 

 

Note 

Several reports use the client’s County to display results so be sure to enter this field.  

j. PSA*: The places list presents a list of values based on the city, state, zip, county selected.  
 

Note 

Several reports use the client’s PSA to display results so be sure to enter this field. 

k. Agency: This field is populated by the places list with the Agency name. 
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7. From the File menu, select Save and Close Address. 
 

Client Phone 
The Demographics page houses many data elements including phone numbers. Phone numbers can also be 
added on Client Phones subpage. The phone numbers visible on the demographics detail page are also visible 
on this subpage. 
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Note 

Because best contact, home and work phone numbers are captured on the 
Demographics page, it is not likely you will use this page to add phone numbers, but 
it is available.  

 
 

If you want to track the effective dates of a phone number you would want to add 
them from the Client Phones subpage instead of Demographics. 

 

 
Role: eCIRTS Worker 

 
1. Navigate to the client’s record and select the Demographics tab. 

 
2. From the File menu, select Edit Demographics. 

 
3. The Demographics detail page displays. The Client Addresses and Client Phone subpages are listed on 

the left.  
 

4. Select the Client Phones. The phone numbers that are visible on the demographics detail page and will 
also be visible on this subpage.  
 

5. To add an additional phone number, from the File menu, select Add Client Phone. 
 

6. The Phone Details page displays. Update the following fields: 
a. Phone Type: Select the type of phone number. 
b. Phone Category: Select Current, Previous, Unknown or Other 
c. Phone Number: enter the phone number in (###)###-#### format. 
d. Extension: enter if applicable 
e. Active: check this box if this phone number currently in use. The phone number must be active to 

display on Demographics. 
f. Primary: check this box if you want this phone number to display on Demographics. 
g. Contact Type: Will default to Consumer and is read only. 



34 
11300 Switzer Road Overland Park, KS 66210 

 

 
 

7. From the File menu, select Save and Close Client Phone. 
 

Follow Up 
Eligibility specialists can manage their day-to-day workload from the My Work page. Any contact records 
assigned to the worker for follow up or subsequent contact attempts will be listed on the My Work > Contacts 
page. However, it is recommended eligibility specialists view their assignments from the Contact queue. There 
are more data elements available in the queue for quick view of the record and filtering options. Also, records 
are visible to all eligibility specialists and supervisors, not just those the contact is assigned to like on My Work. 
(i.e. eligibility specialists covering for each other, supervisors monitoring the work of their staff.)  
 

 
Role: eCIRTS Worker 

 

1. Select the Contacts tab.  
 

2. To view a list of contact attempt follow ups assigned to you, select the following search filters: 
a. Assigned To: search for and select your name if not already selected 
b. Contact Type: SMMC LTCP - Eligibility 
c. Contact Status: Assigned 
d. Reason for Contact: Waitlist Release - Attempt 2 or Waitlist Release - Attempt 3 

 

3. Select Search. Results are returned.  
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Note 

Recommend creating a user saved filter to list all follow ups that require an additional contact 
attempt. The next time you use the Contact queue, you can select your saved Filter from the list 
and click Search Filter. This will populate the search filters, saving you time from looking them up 
again. 

  
4. Select a record to open the contact details page.  

 
5. Follow one of the scenarios: 

a. Unsuccessful Contact 2 
b. Unsuccessful Contact 3 
c. Successful Contact – Client Not Interested 
d. Successful Contact – Client Hospitalized/Nursing Home  
e. Successful Contact – Client Confirms Interest  

 
6. To view a list of follow ups you assigned to yourself in the As Needed: Pre-release Research Follow Up 

section, select the following search filters: 
a. Assigned To: search for and select your name if not already selected. 
b. Contact Type: SMMC LTCP - Eligibility 
c. Contact Status: Follow Up 

 
7. Select a record to open the contact details page.  

 
8. Complete your follow up tasks and document updates in the open contact record. Update the following 

fields: 
a. Short Summary: brief details about follow-up. Should be limited to 2-3 sentences. This field is 

visible on the Contact queue. 
b. Notes: This field is unlimited and does not display on the Contact queue. This field is optional and 

only needed if additional details are needed beyond the Short Summary 
c. Contact Type: remains SMMC LTCP - Eligibility 
d. Reason for Contact: remains Waitlist Release 
e. Contact Status: update to Complete.  
f. Assigned To: defaults to self. Can remove value or leave as is. 

 
9. From the File menu, select Save and Close Contact. 

 
10. Proceed to the Medicaid Waiver Timeline Form section. 
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As Needed: Return to Pipeline 
If a client began the EMS release process but did not finish, he/she has 6 months to contact the eligibility specialist 

to restart the process. The client will not have to start the process from the beginning. A contact record will be 

added and the MLTC program record will be updated.  

 

 
Role: eCIRTS Worker 

 
1. The eligibility specialist will first search for the existing client record.   
 
2. From the existing client search results, select the flyout menu to the right of the client’s name in 

the search results. Select Add Contacts. The Contact Details page displays. 
 

 
 

3. Or, with the client record already open, select the Demographics tab. From the File menu, select 
Add Contact. The Contact Details page displays. 

 
 
 
4. The Contact details page displays. Update the following fields: 

a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: Required. defines how the contact was made. 
h. Anonymous: Leave blank 
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i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: search field. If the Caller already exists on the client's Associated 

People tab, their name will be listed, and the eligibility specialist can pick it from the list to 
populate the field.  

 
If not, the eligibility specialist can close the search window by clicking the X at the top right and 
just type the name into the "Caller if other than client" box on the contact screen.  

 
n. REMINDER!: ADD ASSOCIATED PEOPLE RECORD FOR CALLER. This message displays when a 

value is added to the Caller if Other than Client field. 

 
o. Relationship: enter the relationship of the caller to the client 
p. Contact Type: select SMMC LTCP – Eligibility  
q. Short Summary: Note the contact with the client within 6 months and confirmed interest. Will 

be updated later in the workflow.  
r. Notes: leave blank. Will be updated later in the workflow. 
s. Contact Marker: leave blank. 
t. SNAP Submittal Date: leave blank. 
u. Reason for Contact: Medicaid Eligibility 
v. Referral Type: Return to Pipeline 
w. 701S Appointment Date: leave blank.  
x. Unmet Needs Reason: leave blank. 
y. Assigned To: defaults to self. Can remove value or leave as is. 
z. Screener: leave blank 
aa. Contact Status: Complete  
bb. Duration: will automatically populate after the record is saved. 
cc. Client Primary Language: leave blank.  
dd. Other Language: leave blank.   
ee. Follow Up Date: leave blank.  
ff. Screening Referral Created Date: leave blank.  

 
5. From the File menu, select Save and Close Contact. 
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6. The eligibility specialist will also update the MLTC program record. From the open client record, select 
the Programs tab. A list of program enrollments is displayed. Select the MLTC program record in 
Terminate – APCL Waitlist status.  
 

7. You must first reverse the status of this record before you can update it. From the File menu, select 
Reverse Disposition.  

 
 

8. The page refreshes and the fields are now editable. Update the following fields: 
a. Status: APPL Applicant 

 
 

9. From the File menu, select Save and Close Programs.  
 

10. You may need to update the worker on the Enrollment Provider subpage. You want this client to be 
visible on your My Work page so you can manage your caseload throughout the staffing process and 
level of care determination. You may need to change the enrollment provider from the generic Default 
PSA provider for your PSA to yourself.  
 

11. Complete the steps in the Eligibility Specialist Assigned section if you have never been listed as an 
enrollment provider for this client.  
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12. Otherwise, select your worker record from the list.  

 
 

13. The Enrollment Provider details page displays. Update the following fields: 
a. Primary: check the box 
b. Active: check the box 
c. Start Date: enter the date you are making the change. 
d. End Date: can be blank. 

 
 

14. From the File menu, select Save and Close Enrollment Provider.  
 

15. Proceed to the Medicaid Waiver Timeline Form section. 
 

Pre-release Research Tasks 

If the client is coming off the MLTC waitlist through the EMS release process, several pre-release research tasks 
are completed before making the CARES Referral. The completion of the tasks is recorded as a Contact record 
in eCIRTS. The Pre-release Research Tasks include: 

• Confirm the 3008 is on file. 

• Confirm if the LOC is on file. 

• Confirm Medicaid and DCF status. 

• Send the Waitlist Release Notice 

 
For some PSAs the contact attempts to confirm client interest happen before the Pre-Release Research tasks. 
For other PSAs, the Pre-Release Research tasks come first. Regardless of the order, the steps to complete in 
eCIRTS are the same and both must be completed before making the CARES referral. 
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Sending/Receiving the 3008 Medical Certification Form 

Following a screening if a client is ranked as a five, the screener may send the 3008 Medical Certification form 
to the client for completion by his/her physician. Once returned, the ADRC will scan and save it to a note in 
eCIRTS.  See the Screening Workflows Training Guide for more information. 

Later in the workflow when clients are coming off the MLTC waitlist, the eligibility specialist may find the 3008 
has already been completed, returned and on file. If not, the eligibility specialist will complete the steps to 
obtain a complete 3008 from the client and his/her physician.  

 

 
Role: eCIRTS Worker 

Proceed to one of the following scenarios:  

1. 3008 Received and Complete 
2. 3008 Received and NOT Complete 
3. 3008 Not Received 

 

3008 Received and Complete 

1. Navigate to the Notes tab of the client record to confirm if the 3008 is already on file.  
 

2. If the 3008 has already been sent to the client, there will be a note with Note Type: Referral Packet 
and Note Sub-Type: 3008 or equivalent. The eligibility specialist will check this note to confirm the 
3008 is present and complete. Select the note to open it.  

 
3. Open the attachment to view the 3008 form.  
 

 

Note 

In eCIRTS, you must save the attachment to your device before you can view it.  
 

 
4. If the 3008 is complete, from the note details page, update the following fields:  

a. Note Type: remains Referral Packet 
b. Note Sub-Type: remains 3008 or equivalent. 
c. Note: note the 3008 has been received and is complete 
d. Status: select Complete 
e. Follow Up Date: leave blank.  
f. Note Recipient: leave blank.  
g. Attachment: keep the attached 3008 attached. 
 

5. From the File menu, select Save and Close Notes.  
 

6. Proceed with the rest of the pre-release research tasks. 
 

7. Once all the pre-release research tasks are completed, 3008 details will also be documented on the 
Medicaid Waiver Timeline Form 

 

3008 Received and NOT Complete 

1. Navigate to the Notes tab of the client record to confirm if the 3008 is already on file.  
 

https://mediwareinformationsystems-my.sharepoint.com/personal/jennifer_buck_mediware_com/Documents/05%20FL%20eCIRTS/Training/Helpline-Intake-Elig/eCIRTS%20Screening%20Workflows%20Training%20Guide%20V1%2012-7-23.docx
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2. If the 3008 has already been sent to the client, there will be a note with Note Type: Referral Packet 
and Note Sub-Type: 3008 or equivalent. The eligibility specialist will check this note to confirm the 
3008 is present and complete. Select the note to open it.  

 
3. Open the attachment to view the 3008 form.  
 

 

Note 

In eCIRTS, you must save the attachment to your device before you can view it.  
 

 
4. If the 3008 is NOT complete, the eligibility specialist will follow up with the client. From the note 

details page, update the following fields:  
a. Note Type: remains Referral Packet 
b. Note Sub-Type: remains 3008 or equivalent. 
c. Note: enter details about the 3008 and what is missing 
d. Status: select Follow Up 
e. ADD A NOTE RECIPIENT: This message displays when the status is Follow Up. It is a reminder to 

add this note to a worker’s My Work > Notes queue for follow up. The worker is added as a 
Note Recipient.  

f. Follow Up Date: enter a date you want to be prompted to follow up.  
g. Note Recipient: search for and enter your name as the note recipient.  
h. Attachment: keep the attached 3008 attached. 

 
5. From the File menu, select Save and Close Notes. 

 

NOTE 

The Client has 30 days to return the completed 3008 Medical Certification Form.  If it is 
not returned, on the 31st day eligibility staff will terminate the MLTC and inform the 
client that the information has not been received.  The Client can return to APPL 
Applicant status  if they return the form within 6 months of the EMS Release Date. 
Proceed to the Return to Pipeline section. 

 
6. This note will be visible on the My Work page for the eligibility specialist. This can be helpful and 

serve as a reminder to the specialist to follow up on the 3008. From the My Work page, select the 
Clients > Notes > Follow Up queue. 

 
 

7. A list of notes where the eligibility specialist is the note recipient, and the status is follow up are 
displayed. Use the search filters and the Follow Up Date to narrow this list down to those that 
require follow up today/this week. 
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8. Select the Referral Packet > 3008 or equivalent note from the list.  
 
9. The Note details page displays. Update the following fields: 

a. Note Type: remains Referral Packet 
b. Note Sub-Type: remains 3008 or equivalent. 
c. Note: note the 3008 has been received and is complete 
d. Status: select Complete 
e. Follow Up Date: leave blank.  
f. Note Recipient: leave blank.  
g. Attachment: scan and attach the completed 3008 

 
10. From the File menu, select Save and Close Notes.  

 
11. Proceed with the rest of the pre-release research tasks. 

 
12. Once all the pre-release research tasks are completed, 3008 details will also be documented on the 

Medicaid Waiver Timeline Form 
 

3008 Not Received 

1. If there is NOT a note with Note Type of Referral Packet and Note Sub Type of 3008 or equivalent, 
the eligibility specialist must work with the client to complete one. The eligibility specialist will 
create the note. From the File menu, select Add Note.  

 
2. The Note detail page displays. Update the following fields:  

a. Division: Defaults to AG 
b. Note By: Defaults to self. 
c. Note Date: Defaults to today. 
d. Notes List: select ADRC. 
e. Note Type: Referral Packet 
f. Note Sub-Type: 3008 or equivalent. 
g. Note: enter details when the 3008 was sent to the client 
h. Status: Follow Up  
i. ADD A NOTE RECIPIENT: This message displays when the status is Follow Up. It is a reminder to 

add this note to a worker’s My Work > Notes queue for follow up. The worker is added as a 
Note Recipient.  
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j. Follow Up Date: enter a date you want to be prompted to follow up. 
k. Note Recipient: search for and select your name as the note recipient. 
l. Attachment: none. Later when the 3008 form is received, it will be scanned and saved to this 

same note as an attachment. 

 
 

3. From the File menu, select Save and Close Notes. Send the 3008 Medical Certification form to the 
client for completion by his/her physician. The 3008 Medical Certification form is not printed from 
eCIRTS.  
 

NOTE 

The Client has 30 days to return the completed 3008 Medical Certification Form.  If it is 
not returned, on the 31st day eligibility staff will terminate the MLTC and inform the 
client that the information has not been received.  The Client can return to the APCL 
Waitlist if they return the form within 5 months. (6-month total time to be reinstated 
to the waitlist) Proceed to the Return to Pipeline section. 

 
4. When the 3008 Medical Certification form is returned, it will be scanned and saved to the Referral 

Packet > 3008 or equivalent note in eCIRTS. You can find the note two ways.  
a. My Work page, select the Clients > Notes > Follow Up queue. Select the existing Referral 

Packet > 3008 or equivalent note.  
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b. Search for and select the existing client record. Select the Notes tab. From the list view, 

select the existing Referral Packet > 3008 or equivalent note.  

 
5. The Note details page displays. Update the following fields: 

a. Note: enter details the 3008 being received 
b. Status: Complete  
c. Follow Up Date: Leave blank. 
d. Note Recipient: None needed.  
e. Attachment: scan and attach the completed 3008 forms 

 

6. From the File menu, select Save and Close Notes. 
 

7. Proceed with the rest of the pre-release research tasks. 
 

8. Once all the pre-release research tasks are completed, 3008 details will also be documented on the 
Medicaid Waiver Timeline Form.  

 

Confirm if the Level of Care (LOC) is on File 

The eligibility specialist will confirm if the LOC is already on file and less than 6 months old. Level of Care is 
housed on the Staffing screens in CIRTS. In eCIRTS, Level of Care is housed on the CARES Staffing Form on the 
client’s Forms tab. 

 

 
Role: eCIRTS Worker 

1. The Level of Care data from the Staffing screens in CIRTS will be visible on a CARES Staffing Form in 
eCIRTS. From the client’s record, select the Forms tab. 
 

2. Review the list of completed forms, looking for a CARES Staffing Information form in a Signature or 
Complete status with an Assessment Date within the past 6 months. Click on the form to open it and 
review the details.  
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3. If a LOC exits and is less than 6 months old, a CARES Referral is not needed. Close the form. Document 
the existence of a current LOC in a note. Proceed to the Pre-release Research Task Note section. Then 
proceed to the Medicaid Active section. 

 
 
4. If a LOC does not exist or if a LOC does exist but is more than 6 months old, a CARES Referral is needed. 

Close the form and proceed with the rest of the pre-release research tasks.  
 

5. Once all the pre-release research tasks are completed, LOC status will also be documented on the 
Medicaid Waiver Timeline Form.  
 

Check Medicaid and DCF Status 

The eligibility specialist will check the client’s Medicaid and DCF status outside of eCIRTS and document in 
eCIRTS.  

FUTURE: Medicaid status will also be visible in eCIRTS on the client’s Eligibility tab.  

 

 
Role: eCIRTS Worker 
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1. The eligibility specialist will log into FLORIDA, for example to obtain the client’s Medicaid status. It will 
be documented in the Pre-release Research Tasks Note section.  
 

2. Once all the pre-release research tasks are completed, Medicaid and DCF status details will also be 
documented on the Medicaid Waiver Timeline Form.  
 

Send the Waitlist Release Notice 

Based on the status of the 3008 Medical Certification Form, Level of Care status and Medicaid/DCF application 
status, the ADRC will send one of the following waitlist release notices to the client.  

• 100YMYF - Some form of Medicaid/Yes Form 5000-3008 

• 200NMNF - No Medicaid/No Form 5000-3008 

• 300YMNF - Some form of Medicaid/No Form 5000-3008 

• 400NMYF - No Medicaid/Yes Form 5000-3008 

• 500SSYF - SSI/Yes Form 5000-3008 

• 600SSNF - SSI/No Form 5000-3008 

 

A copy of the notice is not saved in eCIRTS but the notice that is sent will be referenced in the Medicaid Waiver 
Timeline form and in a contact record by the eligibility specialist.  

Most PSAs send these notices out in bulk, outside of eCIRTS. They can also be printed on demand, one by one 
in eCIRTS. 

 

NOTE: The notice CAN be sent before a completed 3008 is on file, but a completed 3008 must be on file before 
a CARES referral can be made.  

 

 
Role: eCIRTS Worker 

1. To print the notice from eCIRTS, navigate to the client’s record and select the Demographics tab.  
 

2. From the Word Merge menu at the top of the page, select the notice.  

 
 

3. The Word Merge preview page opens and shows a preview of the letter.  
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4. Some information auto-populates the notice and other information needs to be manually added. Select 
Open Document. It must be saved to your device first before it can be edited.  
 

5. Select where on your device the notice should be saved.  
 

6. Edit the notice. Once your edits have been made, save your changes to your device.  
 

7. Send the notice to the client. 
 

8. You do not have to save a copy of the notice to a note in eCIRTS but you will note which was sent in the 
Pre-release Research Tasks Note.  
 

9. Once all the pre-release research tasks are completed, waitlist release notice information will also be 
documented on the Medicaid Waiver Timeline Form.  

 

Pre-release Research Tasks Note 

When the client is coming off the MLTC waitlist through the EMS release process, several pre-release research 
tasks are completed before making the CARES Referral. The completion of the tasks is recorded as a contact 
record in eCIRTS. The Pre-release Research Tasks include: 

• Confirm the 3008 is on file. 

• Confirm if the LOC is on file. 

• Confirm Medicaid and DCF status. 

• Send the Waitlist Release Notice 

 

 
Role: eCIRTS Worker 

 
1. The eligibility specialist will first search for the existing client record.   

 
2. From the existing client search results, select the flyout menu to the right of the client’s name in the 

search results. Select Add Contacts. The Contact Details page displays. 
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3. Or, with the client record already open, select the Demographics tab. From the File menu, select Add 

Contact. The Contact Details page displays. 

 
 
 

4. The Contact details page displays. Update the following fields: 
a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: NA 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Contact Type: select SMMC LTCP – Eligibility  
o. Short Summary: Document the completion of the pre-release research tasks, and which 

release letter was sent to the client and when. Should be limited to 2-3 sentences. This field is 
visible on the Contact queue.  

p. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 
and only needed if additional details are needed beyond the Short Summary 

q. Contact Marker: leave blank. 
r. SNAP Submittal Date: leave blank. 
s. Reason for Contact: Waitlist Release 
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t. Referral Type: leave blank. 
u. 701S Appointment Date: leave blank.  
v. Unmet Needs Reason: leave blank. 
w. Assigned To: defaults to self. Can remove value or leave as is. 
x. Screener: leave blank 
y. Contact Status: Complete  
z. Duration: will automatically populate after the record is saved. 
aa. Client Primary Language: leave blank.  
bb. Other Language: leave blank.   
cc. Follow Up Date: leave blank.  
dd. Screening Referral Created Date: leave blank.  

 
5. From the File menu, select Save and Close Contact. 

 
6. Proceed to the Medicaid Waiver Timeline Form section. 

 

As Needed: Pre-release Research Follow Up 
If additional follow up is needed with the client to complete the pre-release research tasks, each is documented 
on a separate Contact record in eCIRTS. 
 

 
Role: eCIRTS Worker 

 
1. The eligibility specialist will first search for the existing client record.   
 
2. From the existing client search results, select the flyout menu to the right of the client’s name in the 

search results. Select Add Contacts. The Contact Details page displays. 
 

 
 

3. Or, with the client record already open, select the Demographics tab. From the File menu, select Add 
Contact. The Contact Details page displays. 
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4. The Contact details page displays. Update the following fields: 
a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: NA 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Contact Type: select SMMC LTCP – Eligibility  
o. Short Summary: Document the need for follow up. Should be limited to 2-3 sentences. This field is 

visible on the Contact queue.  
p. Notes: This field is unlimited and does not display on the Contact queue. This field is optional and 

only needed if additional details are needed beyond the Short Summary  
q. Contact Marker: leave blank. 
r. SNAP Submittal Date: leave blank. 
s. Reason for Contact: Waitlist Release 
t. Referral Type: leave blank. 
u. 701S Appointment Date: leave blank.  
v. Unmet Needs Reason: leave blank. 
w. Assigned To: defaults to self. Can remove value or leave as is.  
x. Screener: leave blank 
y. Contact Status: Follow Up.   
z. Duration: will automatically populate after the record is saved. 
aa. Client Primary Language: leave blank.  
bb. Other Language: leave blank.   
cc. Follow Up Date: leave blank.  
dd. Screening Referral Created Date: leave blank.  
 

5. From the File menu, select Save and Close Contact. 
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6. Proceed to the Follow Up section. 
 
 

Medicaid Waiver Timeline Form 
The eligibility specialist will document the completion of the pre-release research tasks and additional 
information as the client progresses through the staffing and eligibility process. The eligibility specialist will 
update this form many times during the release-staffing-eligibility process for the client. The status on the form 
is important. It will be updated to the ‘last step completed’ for the client.  Status changes make it easy for 
specialists to group and manage their caseloads on the My Work page. See the View Last Step Completed 
section for more information.  
 

 
Role: eCIRTS Worker 

 
1. The eligibility specialist does not have to create a Medicaid Waiver Timeline form until the pre-release 

research tasks are completed and the client has confirmed interest. The client’s MLTC enrollment will 
be in APPL status before the Medicaid Waiver Timeline Form is created.  
 

2. To add a Medicaid Waiver Timeline form, navigate to the client’s record and select the Forms tab.  
 

3. From the File menu, select Add Form.  
 
4. Select the Medicaid Waiver Timeline Form from the list.  
 
5. The form opens. In the header, update the following fields: 
 

a. Status: defaults to Draft. Change to Pending so it will be visible in the Forms Queue described 
in the View Last Step Completed section.  

b. Assessment Type: EMS Release 
c. Last Completed: remains blank. Will auto populate when the form status equals Complete. 
d. Data Entered By: remains blank. Will auto populate when the form status equals Complete. 

 
 
6. Demographic information for the client auto populates on the form. It is pulling from the client’s 

Demographic page.  
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7. Additional questions about the status of the client’s release process are displayed. The eligibility 

specialist will answer each as the information is known.  
 

NOTE 

With a future enhancement, eligibility specialists will be able to use the Refresh 
enhancement on the Medicaid Waiver Timeline form. Every time the form is saved and the 
value in the Refresh field is Yes, a behind the scenes process will look in several areas of the 
client’s record to fill in responses to the questions on the Medicaid Waiver Timeline form. 
Using this enhancement will reduce the amount of data entry the eligibility specialist has to 
complete. 

 
 
8. Each time an update is made, the form should be saved, and the Assessment Type may need to be 

updated per the table below: 

Assessment Type Description  

APS Referral received from Adult Protective Services and should be 
treated with priority 

EMS Release  A new EMS release referral and the CARES referral packet is not 
yet complete.  

3008 Incomplete An EMS referral with an incomplete 3008. Follow up is required. 

DCF Pending EMS referral is pending DCF financial eligibility determination  

CARES Referral Pre-release research tasks are complete, and the CARES Referral 
has been made.  

Financial Eligibility Pending Staffing has been completed and the case is pending financial 
eligibility determination 

Medicaid Eligibility Pending Staffing has been completed and the case is pending Medicaid 
eligibility determination 

Medical Eligibility Pending Staffing has been completed and the case is pending medical 
eligibility determination 

SSI/TXIX/LTC Staffing has been completed and the client already has SSI, TXIX 
or LTC benefits. 
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9. In the header, update the following fields: 

a. Status: remains Pending until the client is active and the case is closed 
b. Assessment Type: per table above 
c. Last Completed: remains blank. Will auto populate when the form status equals Complete. 
d. Data Entered By: remains blank. Will auto populate. 

 
10. From the File menu, select Save and Close Forms. 

 
11. Proceed to the Create CARES Referral section. 

 

View Last Step Completed    
At any time, the eligibility specialist can keep track of their clients as they progress through the release process. 

The Assessment Type on the Medicaid Waiver Timeline Form is updated with the last step completed. The My 

Work > Forms Queue can be filtered to display the specialist’s caseload by last step completed. The status of 

the Medicaid Waiver Timeline Form must be Pending to be visible in this queue. 

• APS 

• EMS Release 

• 3008 Incomplete 

• CARES Referral 

• DCF Pending 

• SSI/TXIX/LTC 

• Financial Eligibility Pending 

• Medicaid Eligibility Pending 

• Medical Eligibility Pending 

 

 
Role: eCIRTS Worker 

 

1. Navigate to the My Work page.  

 

2. From the right side of the page, select Tasks > My Management > Forms Queue. 
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3. The Form queue displays. Update the following search filters: 

a. Form: Medicaid Waiver Timeline 

b. Assessment Type: Select the last step completed you wish to view.  

 
 

4. Select Search. A list of matching results is displayed. Medwaiver Timeline Forms on which you are the 

Assessor/Worker are listed.  
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5. Select the form from the list to open the Medicaid Waiver Timeline form for the client.  
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6. Select the View Consumer link instead if you want to open the full client record. Select the Forms tab 

to view the Medicaid Waiver Timeline. 

 
 

Create CARES Referral  
When the pre-research release tasks are complete and the client has been contacted and confirmed interest, 
the referral packet is considered complete, and the CARES referral can be made. The CARES referral will be 
made within eCIRTS. A separate email will no longer be needed.  
 

 
Role: eCIRTS Worker 

 
1. Navigate to the client’s record. Select the Programs tab. A list of existing program enrollments is 

displayed. From the File menu, select Add Program. Update the following fields: 
a. Division: This system-required field will display AG and is read only. 
b. Referred From: select the referral source for this client.  
c. Referral Date: This date reflects when the referral to the program was made and defaults to 

today. It can be changed if needed.  The other date fields on this page CANNOT be earlier than 
the Referral Date.  

d. Program: select CARES. 
e. CARES PSA: select the CARES PSA 
f. Service: leave blank. 
g. Status: select APPL Applicant 
h. Status Effective Date: This field reflects the status start date and will change each time the 

Status is changed. The Track Status subpage is very helpful for viewing a history of the statuses. 
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i. Historical Start Date/Record Created Date: This field is used to record when Program record 
was created. eCIRTS uses this date to enforce when a billing can begin under this program for 
the client. 

j. Enrollment Provider. Always Select Default Provider Worker: Search for and select the CARES 
Generic Worker for your CARES PSA. Search by Last Name = CARES. Be specific. Select 2A or 2B.  

  
k. AHCA County: this field is ready only but will be populated later by the interface for MLTC 

program record only. 
l. Enrollment Exception: This will be used to explain when an enrollment is added on an 

exception basis because the Client is under 60, for MLTC, for Nutrition or to record services 
after DOD. Leave this field blank if it does not apply. 

m. Exception Reason: When an enrollment exception is selected, an exception reason should be 
selected.  

n. CARES Staffing Reviewer: leave blank. This will be completed later by the CARES Assessor. 
o. CARES Staffing Date: leave blank. This will be completed later by the CARES Assessor or stored 

procedure. 
p. CARES Provider: leave blank. This will be completed later by the CARES Assessor. 
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2. From the File menu, select Save and Close Program. 
 

3. The CARES Staff Assistant will be the next worker to update this case when reviewing the packet to 
ensure it’s complete. Please see the CARES EMS Release Workflow Training Manual.  
 

4. Proceed to the New LOC – Eligibility Forms section. 
 

 

As Needed: Referral Packet Incomplete 
In the previous section, the eligibility specialist added the CARES program record which serves as making the 
CARES Referral. Before a new referral is assigned to a CARES Assessor, the packet is reviewed for completeness. 
If there is something missing, the CARES Staff will request additional information from the eligibility specialist in 
eCIRTS by updating the status and reassigning the CARES program record back to the specialist. Once the 
missing information/documentation is obtained, the eligibility specialist will update the status on the CARES 
program record again and reassign it to the CARES staff.  
 

 
Role: eCIRTS Worker 

 

1. Eligibility specialists will be notified of a returned CARES referral by monitoring My Work. Returned 

referrals will be visible in the My Work > Clients > Programs > Referral Returned queue.  
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Note 

Supervisors can view the returned referrals of their staff. This is done by updating the filters in 
the My Work > Wait List queue. Update the following filters: 

Program begins with CARES. 

Status Begins with Referral Returned 

Enrollment Provider Equal To: Search for and select the name of the specialist assigned to the 
returned referral. 

 
 
 

2. Each record in this queue needs to be reviewed and follow-up actions taken to obtain the missing 
information and/or documentation. Select the record from the list to open the full client record.  
 

3. The CARES staff completed the CARES ADRC Return Form to document the missing 
information/documentation. The eligibility specialist will review it. Select the Forms tab. Select the 
completed CARES ADRC Return Form from the list.  
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4. Review the details in the form then close the form.   

 
 

5. The eligibility specialist will add the missing information/documentation to the existing 3008 or 
equivalent note. Select the Notes tab.  Select the completed CARES Referral Packet > 3008 or 
equivalent note from the list.  

 
 

6. The Note details page displays. The note is in complete status and not editable. From the File menu, 
select Unlock Record. 
 

7. The page refreshes and the status of the note changes to Pending. Update the following fields:  
a. Note: Add an update about the provided information/documentation. Click Append Text to 

Note 
b. Status: Complete 
c. Attachments:  attach the requested missing documentation if any 
d. Note Recipient: none needed. 
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8. From the File menu, select Save and Close Notes.  
 

9. The eligibility will now update the CARES program record, assigning it back to the CARES staff. Select 

the Programs tab. From the list. Select the CARES Program record in Referral Returned status.  

 
 

10. The Program details page displays. Update the following fields: 

a. Status: APPL Applicant 

b. Status Effective Date: Updates automatically when Status changes 
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11. From the File menu, select Save Program. Do NOT select Save and Close Program.  

 

12. This record needs to be reassigned back to CARES. Select the Enrollment Provider subpage. Select the 

Generic CARES worker from the list.  

 
 

13. The Enrollment Provider details page displays. Update the following fields: 
a. Start Date: Update to today. 
b. End Date: leave blank. 
c. Primary: check this box 
d. Active: check this box. 
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14. From the File menu, select Save and Close Enrollment Provider.  
 

15. The CARES Staff Assistant will be the next worker to update this case when reviewing the packet to 
ensure it’s complete. Please see the CARES EMS Release Workflow Training Manual.  
 

16. Proceed to the New LOC – Eligibility Forms section. 
 

As Needed: Lost Contact – Close the Case 
When a CARES referral has been made and the CARES Assessor is not able to contact the client to schedule the 

assessment, the CARES Assessor will notify the eligibility specialist to close the case via a note in eCIRTS. 

 

Role: eCIRTS Worker 

1. The eligibility specialist will view the note sent by the CARES Assessor from the My Work page. 

 

2. Select the Clients > Notes > Complete queue. 

 
 

3. Locate the note with the following information: 

a. Note Type: Case Closure 

b. Note Sub Type: LC=Lost Contact 

 

4. Select the note from the list to view the note details.  Select the View link to open the full client record.  
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5. The eligibility specialist will also update and complete the Medicaid Waiver Timeline form. Navigate to 

the client’s Forms tab. Select the open Medicaid Waiver Timeline form from the list.  

 

6. Update any remaining questions in the form. Update the following fields in the header: 

a. Status: Complete 

b. Data Entered By: default to self.  You cannot change it. 

c. Last Completed: defaults to today.  You cannot change it. 

 

7. From the File menu, select Save and Close Forms.  

 

8. Finally, the eligibility specialist will close the MLTC  program record. The CARES Assessor is responsible 

for closing the CARES program record. From the open client record, select the Programs tab. A list of 

program enrollments is displayed. Select the MLTC program record in APCL status. Update the 

following fields: 

a. Status: Terminate – APPL Applicant 
b. Termination Reason: Lost Contact 
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c. End Date: defaults to today 

 
 

9. No changes are needed to the Enrollment Provider. That can remain the Generic  

 

10. From the File menu, select Save Programs.  

 
11. Select the Enrollment Provider subpage. Change the Enrollment Provider from yourself to the generic 

default worker for your PSA so this case no longer displays on your My Work page.  

 

New Level of Care (LOC) – Eligibility Forms 
After the CARES Referral is made, the eligibility specialist will wait for CARES to complete the staffing process 
and determine the Level of Care for the client before proceeding with the release process.  

Daily, the eligibility specialist, or supervisor, will run the Level of Care (LOC) report from eCIRTS which lists cases 
where the staffing process has been completed and the LOC determinations made for the EMS releases. For 
each new LOC determination, the eligibility specialist will update the Med Waiver Timeline form for the client in 
eCIRTS, fax the 2515 HCBS Waiver Eligibility Certification form to DCF and document it was sent in a contact 
note in eCIRTS.  

 

 

Role: eCIRTS Worker 

1. Daily, each ADRC will run the Level of Care report from eCIRTS.   

NOTE 

 You can also find a list of your clients that are pending LOC by using the Forms Queue.  
Search by Assessment Type = CARES Referral. See the View Last Step Completed 
section. 

 
2. If the client is SSI, TXIX or LTC, update the Medicaid Waiver Timeline form. Navigate to the clients 

record and select the Forms tab. Select the Pending Medicaid Waiver Timeline form from the list. 
Update the following fields: 

a. ASSESSOR/CM: Assessment date:: enter the date or use the stored procedure to populate. 



66 
11300 Switzer Road Overland Park, KS 66210 

 

b. Staffing Date: enter the date or use the stored procedure to populate. 

c. Level of Care Effective Date: enter the date or use the stored procedure to populate. 

d. The remaining fields will be added later in the workflow and should remain blank for now.  

e. In the header, keep the form status as Pending. 

f. Assessment Type: SSI/TXIX/LTC 

 

 
 

3. From the File menu, select Save and Close Forms. The eligibility specialist will update this record again 
once the client becomes MLTC active.  
 

4. For each client on the report that is NOT SSI, TXIX or LTC, the assigned eligibility specialist will fax the 
2515 (HCBS Waiver Eligibility Certification Form) to DCF outside of eCIRTS and document that it has 
been sent in a contact note in eCIRTS. DCF Determines financial eligibility and communicates to ACHA.  
 

5. The eligibility specialist will first search for the existing client record.   
 

6. From the existing client search results, select the flyout menu to the right of the client’s name in the 
search results. Select Add Contacts. The Contact Details page displays. 

 
 
7. Or, with the client record already open, select the Demographics tab. From the File menu, select Add 

Contact. The Contact Details page displays. 
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8. The Contact details page displays. Update the following fields: 

a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: NA 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Contact Type: select SMMC LTCP – Eligibility  
o. Short Summary: Document the 2515 was sent to DCF. Should be limited to 2-3 sentences. This 

field is visible on the Contact queue.  
p. Notes: leave blank. Will be updated later in the workflow. 
q. Contact Marker: leave blank. 
r. SNAP Submittal Date: leave blank. 
s. Reason for Contact: Medicaid Eligibility 
t. Referral Type: leave blank. 
u. 701S Appointment Date: leave blank.  
v. Unmet Needs Reason: leave blank. 
w. Assigned To: defaults to self. Can remove value or leave as is. 
x. Screener: leave blank 
y. Contact Status: Complete  
z. Duration: will automatically populate after the record is saved. 
aa. Client Primary Language: leave blank.  
bb. Other Language: leave blank.   
cc. Follow Up Date: leave blank.  
dd. Screening Referral Created Date: leave blank.  

 
9. From the File menu, select Save and Close Contact. 

 
10. OPTIONAL: Some PSAs save a copy of the 2515 form as an attachment to a note in eCIRTS. 

Documentation for a client is housed on the Client > Notes tab. From the open client record, select the 
Notes tab. From the File menu, select Add Note. The Note Details page displays. Update the following 
fields: 

a. Division: Will default to AG 
b. Note By: Will default to the user creating the Note.  
c. Note Date: Will default to today. 
d. Note Type: Uploaded Forms  
e. Note Sub-Type: Select 2515 HCBS Waiver Eligibility 
f. Description: leave blank 
g. Note: enter any additional notes 
h. Status: Select Complete  
i. Date Completed: When the Note Status equals Complete, the Date Completed field populates 

automatically and is read only. 
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j. Attachments: attach a copy of the 2515 HCBS Waiver Eligibility Certification form to the note 
k. Recipients: NA  

 
 

11. From the File menu, select Save and Close Notes.  
 

12. Once the 2515 is sent, the eligibility specialist will also update the Medicaid Waiver Timeline form. 
Navigate to the client record and select the Forms tab.  
 

13. Select the existing Medicaid Waiver Timeline form from the list. Update the following fields: 
a. 701B Completed: enter the date or use the stored procedure to populate. 

b. LOC Staffing Date: enter the date or use the stored procedure to populate. 

c. 2515 & LOC to DCF Date: enter the date. 

d. The remaining fields will be added later in the workflow and should remain blank for now.  

e. In the header, keep the form status as Pending. 

f. Assessment Type: DCF Pending 

 
14. From the File menu, select Save and Close Forms.  

 
15. Once AHCA has the LOC and program recommendation information from CIRTS and the financial 

eligibility information from DCF, AHCA will provide the MTLC active dates two to three times a month 
via the ‘MLTC file.’  
 

16. Proceed to the Medicaid Active – Close the Case section.  
 

Medicaid Active - Close the Case 
Once the client is active for MLTC, the MCO providers will manage the client’s case and complete the annual 

assessment with the CARES staff. The eligibility specialist will close the loop with the client once they become 

active but will not have a role in the annual review process.  
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Role: eCIRTS Worker 

1. When the MLTC file from AHCA is imported, the client’s MLTC or PACE program record will be 
added/updated. The status will be active, and the Medicaid plan information will be listed under the 
Enrollment Provider tab.  If the client’s name, SSN or Medicaid ID has been updated in the MLTC 
interface file, the client’s data will also be updated in eCIRTS on the Demographic page. 
 

2. The eligibility specialist can use reports and/or monitor their caseload for those that are MLTC active on 
My Work. Select My Work. Under Tasks > My Management, select Forms Queue.  

 
 

3. The Forms queue displays. Update the following search filters:  
a. Form: Medicaid Waiver Timeline AND 
b. Assessment Type: DCF Pending OR 
c. Assessment Type: SSI/TXIX/LTC AND   
d. Status: Pending 
e.    

 
 

4. A list of clients that were DCF Pending or SSI/TXIX/LTC the last time you updated the Medicaid Waiver 
Timeline form are listed. Select the Date Last Modified column to sort the list of forms in ascending 
order, to see the oldest first. Since the MLTC file from AHCA is imported every two weeks, it’s likely the 
clients on this list are now MLTC active. You can check by Clicking the View Consumer link to open the 
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full client record.

 
 

5. Select the Programs tab and note the status of the MLTC and other open program records.  

 
 

6. The eligibility specialist may need to update the status of one or more of the program records for the 
client now that the client MLTC active. From the open client record, select the Programs tab. A list of 
program enrollments is displayed.  

 
 

7. Select the program record that needs to be terminated. The Program details page displays. Update the 
following fields: 

a. Status: Terminate – Active, Terminate - APPL Applicant, or Terminate – APCL Waitlist 
b. Termination Reason: Moved to Managed Long Term Care 
c. End Date: populates to today. Update if needed.  
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8. From the File menu, select Save and Close Programs. You do NOT need to update the worker on the 
Enrollment Provider subpage.  
 

NOTE 

The ADRCs can run the following reports in eCIRTS to identify enrollments that need to 
be terminated for the newly active clients.  

a. MLTC Enrollees Receiving Services in Another Program 

b. ACTV PACE Clients who are ACTV, APPL or APCL in Another Program 
c. Active MLTC Clients Who are ACTV, APCL or APPL in Another Program 
d. Clients who are ACTV, APCL or APPL in the same program multiple times 
e. ACTV, APPL, APCL Clients who have moved to Another PSA 

 
9. The eligibility specialist will complete the Medicaid Waiver Timeline form. Navigate to the clients 

record and select the Forms tab. Select the Pending Medicaid Waiver Timeline form from the list. 
Update the following fields: 

a. Medicaid Approved/Denied Date: enter the date. 

b. APPL End Date: enter the date or use the stored procedure to populate. 

c. APPL Termination Reason: enter the reason or use the stored procedure to populate. 

d. ACTV Start Date: enter the date or use the stored procedure to populate. 

e. In the header, change the form status to Complete. 

f. Assessment Type: remains DCF Pending or SSI/TXIX/LTC. Some PSAs may choose to change it 

back to EMS Release.  

  
 

10. From the File menu, select Save and Close Forms. The process is complete.  

 

11. OPTIONAL: The eligibility specialist may contact the client to confirm all needs are met. If this is done 
the eligibility specialist will add a contact note in eCIRTS. Navigate to the client’s Demographics tab. 
From the File menu, select Add Contact.  
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12. The Contact details page displays. Update the following fields: 
a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: NA 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Contact Type: select SMMC LTCP – Eligibility  
o. Short Summary: Document the closure of the case. Should be limited to 2-3 sentences. This 

field is visible on the Contact queue.  
p. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 

and only needed if additional details are needed beyond the Short Summary  
q. Contact Marker: leave blank. 
r. SNAP Submittal Date: leave blank. 
s. Reason for Contact: Medicaid Eligibility 
t. Referral Type: leave blank. 
u. 701S Appointment Date: leave blank.  
v. Unmet Needs Reason: leave blank. 
w. Assigned To: defaults to self. Can remove value or leave as is. 
x. Screener: leave blank 
y. Contact Status: Complete  
z. Duration: will automatically populate after the record is saved. 
aa. Client Primary Language: leave blank.  
bb. Other Language: leave blank.   
cc. Follow Up Date: leave blank.  
dd. Screening Referral Created Date: leave blank.  

 
13. From the File menu, select Save and Close Contact. The process is complete. 

 

APS to ALF Referral  
APS to ALF referrals are received by the eligibility specialist via email when a client is removed from his/her 
home and placed in an ALF. These cases will be handled as high priority. The eligibility specialist will complete a 
subset of the steps for an EMS Release: 
 

 

Role: eCIRTS Worker 

1. Eligibility specialist will be assigned to the case outside of eCIRTS.  
 

2. The person making the assignment or the eligibility specialist him/herself, will create the MLTC 
program record. Navigate to the client’s record. From the open client record, select the Programs tab. 
From the File menu, select Add Program.  
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3. The program details page displays. Update the following fields: 

a. Division: This system-required field will display AG and is read only. 
b. Referred From: select the referral source for this client.  
c. Referral Date: This date reflects when the referral to the program was made and defaults to today. 

It can be changed if needed.  The other date fields on this page CANNOT be earlier than the 
Referral Date.  

d. Program: select MLTC. 
e. Service: leave blank. 
f. Status: select APPL Applicant 
g. Status Effective Date: This field reflects the status start date and will change each time the Status is 

changed. The Track Status subpage is very helpful for viewing a history of the statuses. 
h. Historical Start Date/Record Created Date: This field is used to record when Program record was 

created. eCIRTS uses this date to enforce when a billing can begin under this program for the client. 
i. Enrollment Provider. Always Select Default Provider Worker: Search for and select the CARES 

Generic Worker for your CARES PSA. Be specific. Select 2A or 2B.  

  
j. AHCA County: this field is ready only but will be populated later by the interface for MLTC program 

record only. 
k. Enrollment Exception: This will be used to explain when an enrollment is added on an exception 

basis because the Client is under 60, for MLTC, for Nutrition or to record services after DOD. Leave 
this field blank if it does not apply. 

l. Exception Reason: When an enrollment exception is selected, an exception reason should be 
selected.  
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4. From the File menu, select Save and Close Programs.  
 

5. The eligibility specialist obtains the 3008 or equivalent from the APS/API or the ALF worker. 
 

6. The eligibility specialist creates the Medicaid Waiver Timeline form. 
 

7. The eligibility specialist Creates the CARES Referral.   
 

8. The eligibility specialist adds a contact note in eCIRTS summarizing the completion of the referral tasks.  
 

9. The eligibility specialist will first search for the existing client record.  
 
10. From the existing client search results, select the flyout menu to the right of the client’s name in the 

search results. Select Add Contacts. The Contact Details page displays. 
 

 
 

11. Or, with the client record already open, select the Demographics tab. From the File menu, select Add 
Contact. The Contact Details page displays. 
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12. The Contact details page displays. Update the following fields: 

a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: Required. defines how the contact was made. 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Relationship: leave blank 
o. Contact Type: select SMMC LTCP – Eligibility  
p. Short Summary: brief details about the completion of the tasks above. Should be limited to 2-3 

sentences. This field is visible on the Contact queue. 
q. Notes: This field is unlimited and does not display on the Contact queue. This field is optional and 

only needed if additional details are needed beyond the Short Summary 
r. Contact Marker: leave blank. 
s. SNAP Submittal Date: leave blank. 
t. Reason for Contact: Medicaid Eligibility 
u. Referral Type: APS to ALF  
v. 701S Appointment Date: leave blank.  
w. Unmet Needs Reason: leave blank. 
x. Assigned To: defaults to self. Can remove value or leave as is.  
y. Screener: leave blank 
z. Contact Status: Complete  
aa. Duration: will automatically populate after the record is saved. 
bb. Client Primary Language: leave blank. This field is used when the screening referral from the 

Helpline is created.  
cc. Other Language: leave blank. This field is used when the screening referral from the Helpline is 

created.  
dd. Follow Up Date: leave blank.  
ee. Screening Referral Created Date: leave blank. 
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13. From the File menu, select Save and Close Contact. 

 

Regaining Eligibility 
Some cases assigned to eligibility specialists are clients who are regaining eligibility. Eligibility specialists provide 
Medicaid application assistance to these clients mostly outside of eCIRTS but will document their actions taken 
with the client in eCIRTS contact notes.  

 

Role: eCIRTS Worker 

1. The eligibility specialist will call the client and walk them through the process of completing the paper 
application. The specialist will document the contact on a contact record in eCIRTS.  
 

2. The eligibility specialist will first search for the existing client record.  
 
3. From the existing client search results, select the flyout menu to the right of the client’s name in the 

search results. Select Add Contacts. The Contact Details page displays. 
 

 
 

4. Or, with the client record already open, select the Demographics tab. From the File menu, select Add 
Contact. The Contact Details page displays. 

 
 
 
5. The Contact details page displays. Update the following fields: 

a. Division: Required. Defaults to AG as is read only. 
b. Contact Date: Required. defaults to today and is editable if needed. 
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c. Contact Time: Required. defaults to now and is editable if needed. 
d. Received By: Required. defaults to the eligibility specialist adding the contact record. 
e. PSA: Required. Select your PSA from the list or populated by Stored Procedure 
f. Current Task: Select Eligibility 
g. Contact Method: Required. defines how the contact was made. 
h. Anonymous: Leave blank 
i. eCIRTS ID: populates automatically and is read only. 
j. Client First Name: populates automatically.  
k. Client Last Name: populates automatically.  
l. Call Back Phone: populates automatically – update if needed. 
m. Caller if other than Client: leave blank.  
n. Relationship: leave blank 
o. Contact Type: select SMMC LTCP – Eligibility  
p. Short Summary: brief details about the contact with the client to complete the application. Should 

be limited to 2-3 sentences. This field is visible on the Contact queue. 
q. Notes: This field is unlimited and does not display on the Contact queue. This field is optional and 

only needed if additional details are needed beyond the Short Summary 
r. Contact Marker: leave blank. 
s. SNAP Submittal Date: leave blank. 
t. Reason for Contact: Regaining Eligibility 
u. Referral Type: leave blank.  
v. 701S Appointment Date: leave blank.  
w. Unmet Needs Reason: leave blank. 
x. Assigned To: search for and select your name if not already selected. 
y. Screener: leave blank 
z. Contact Status: Follow Up  
aa. Duration: will automatically populate after the record is saved. 
bb. Client Primary Language: leave blank. This field is used when the screening referral from the 

Helpline is created.  
cc. Other Language: leave blank. This field is used when the screening referral from the Helpline is 

created.  
dd. Follow Up Date: enter a date you want to be prompted to follow up.  
ee. Screening Referral Created Date: leave blank. 

 



78 
11300 Switzer Road Overland Park, KS 66210 

 

 
 

6. From the File menu, select Save and Close Contact.   

 
7. If the client is filling out the application, the eligibility specialist’s job is done for now. The client will sign 

the completed application and return it to the specialist. The eligibility specialist will fax the signed 
application and requested verifications to DCF and update the existing contact record.  
 

8. If the eligibility specialist filled out the application for the client over the phone, the specialist will mail 
the completed application to the client for signature. The client will sign the completed application and 
return it to the specialist. The eligibility specialist will fax the signed application and requested 
verifications to DCF and update the existing contact record. 
 

9. This contact can be tracked on the Contacts queue because it will be updated when the application is 

received from the client. Use the following search filters:  

a. Assigned To: search for and select your name if not already selected. 

b. Contact Status: Follow Up 

c. Reason for Contact: Regaining Eligibility 

d. Follow Up Date: enter date parameters.  
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Note 

Recommend creating a user saved filter to list all regaining eligibility cases that require follow up. 
The next time you use the Contact queue, you can select your saved Filter from the list and click 
Search Filter. This will populate the search filters, saving you time from looking them up again. 

 
 
 

10. Click Search. 
 

11. Select the Regaining Eligibility contact record created in step 1 from the list. The contact details page 
displays. Update the following fields:  

a. Contact Type: remains SMMC LTCP – Eligibility 
b. Reason for Contact: remains Regaining Eligibility 
c. Short Summary: brief details about receiving application and faxing to DCF. Should be limited 

to 2-3 sentences. This field is visible on the Contact queue. 
d. Notes: This field is unlimited and does not display on the Contact queue. This field is optional 

and only needed if additional details are needed beyond the Short Summary 
e. Contact Status: change to Complete. 

 

12. From the File menu, select Save and Close Contact. 
 

 


